Apex clothing sticking to world origin after 4.14

Hello everyone!

I’m having a very specific issue in all my characters using apex cloth simulation, it appears some of the vertexes I left with 0 sim weight (so they would anchor the cloth to the character) are getting skinned to the world origin instead of their appropriate bones.

I already tried reskining and repainting cloth weights with the latest version of the physx plug in (for maya 2016) but that doesn’t seem to fix the issue.

Unit23 already mentioned this here https://answers.unrealengine.com/questions/527580/assets-often-break-when-imported-to-open-project.html but just I case I wanted to highlight this issue specifically.

Hello Mordragos,

Is this occurring in a new blank project or did you upgrade an existing project?

Would you test this is a new project using the assets you are experiencing issues with so I can verify this occurs in the default 4.14 engine version, and isn’t and upgrading issue.

Could you also supply me with a test asset (can be very simple) so I can have a similar test case to your own?

Let me know if you have further questions or need additional assistance.

Cheers,

Andrew Hurley

Hi Andrew,

I just finished doing some tests and I turn out after re skinning the cloth (with the latest version of physx plug in) and re exporting the character and cloth from maya into a new blank project does solve the issue!

I’ll try importing my assets into a new project and then re importing the new apx file.

just a head up though, I could import the old apx file without any warning but when I tried applying I got a crash

anyway thanks for the help!

Hi, I’m having issues with APEX cloth in UE4 4.14 being rotated (and sometimes scaled) incorrectly. I’ve posted some sample files that should demonstrate the issue with the rotation bug I’ve seen, at least:
https://dl.dropboxusercontent.com/u/100092412/414ApexClothTestProjects.zip

Files inside:
good.blend
bad.blend
good.FBX
bad.FBX
good.APX
bad.APX

If you import good.FBX to UE4 and apply good.APX to it, you get the same behavior in 4.13 and 4.14.

If you import bad.FBX to UE4 and apply bad.APX to it, you get good behavior in 4.13 and broken behavior in 4.14 where the simulated mesh is rotated incorrectly.

This is a simple test plane mesh created in blender and weighted to an armature, before being exported as .fbx and imported to ue4. The .apx files are created via ClothingTool.

The only difference between good.blend and bad.blend is that the root bone of the armature is rotated. I believe this is what’s breaking APEX cloth for my characters in 4.14: the root bone of the character’s skeleton isn’t vertical in it’s reference pose.