Download

Apex Clothing Import Error

I’m trying to add Apex Cloth to my skeletal mesh. I’ve tried and tried again with different setting each time but have yet to get it working. I can make the Apex Cloth in maya and it works but when I try to bring it into UE4, I get an error saying that the apex cloth references bones that don’t exist in the skeletal mesh. The problem is that the bones do exists. I’ve attached some screens to show what I’m seeing. Does anyone know why this is happening?

c7748ab84fd3514cccd3a46c49b22805847006cd.jpeg
432020ec6ad94037441b68e298d3ca3cf4293ee5.jpeg

Any help would be greatly appreciated.

In that case, the bone name which the message shows is “yellowRobeSmallDemon_RIG_hi:strap_L_01_joint” but the correct bone name should be “strap_L_01_joint”. right? I don’t know why the bone names became weird. If you export Apex file to XML type (.apx), you can open the file from a text editor and can modify weird bone names to correct names.

It worked! Thank you! I still wonder why it saved the names differently but as long as there is a way to fix it, this will work.

Thanks Buddy it works for me