Download

APEX Cloth problem

(Problem is solved)
Hello!

I’m trying to practice using apex cloth for hair physics. I have done the procedures from making the mesh to applying the apex cloth into it in Maya. I use no rigid body nor collision whatsoever. I simply skin the mesh to a bone (to allow the physx to work). Everything is done, i’ve checked the physics in maya and it went just fine.
However when i tried to import the files to unreal, the physx didn’t work, at all.

Things i’ve tried :
-I already know with the material channel/ID whatever it is. Applied it to the material corresponding to the mesh, and no luck.
-Changing the Y-Z axis on the FBX. Still no luck
-Things get funny when i tried to export the .apx with cm conversion to cm (the default was cm to meter). It works! (yay!). BUT… there’s definitely something wrong about this.

5ce003e0c7d0569d0651a3453b518eaa83b19135.jpeg
(it stretches to the underground… but the hair does wiggle, so it works but… what the…)

where it supposedly had to be like this

8ea97c223a63b00071b30247a8bde28b85e853a0.jpeg

Oh, i’m using 4.14. Does anyone have any solution or at least suggestion for this?
Thank you!

*update
-Tried to change Maya’s scene orientation to Y-up (just like its default). Apex hates Y-up, and behaves like Z-up eventhough in Y-up scene.
-Tried to check T0 as ref pose when importing. Hair went haywire after applied with the apex.
-Still trying…

*update
-i tried the most simple apex cloth i can built. A simple plane, 2 bones (a bone and its end), and usual apex configuration.
ss5.JPG
the result is
ss6.JPG
So i guess my previous hair mesh wasn’t the culprit. This is getting frustating. and either i’m too impatient or still no luck on getting someone who knows how to fix this…

Ok, found it.

For the record. Basically i had 2 bones. A standart bone as the root. and the end bone. Previously i was skinning my hair to the first bone, which made things weird. Solved this by using the 2nd bone (the end bone) and now it works well. Also don’t foget to change the conversion from meter (physx maya exporter default) to cm.

I think either apex/unreal hates it when i skin my hair to its root folder, and only allows to skin the hair into its child’s bones.

1967d6465e172269ca71bab2d77dbd2623b285ec.jpeg
(The UV was corrupted somehow… grey mesh it is)