Download

Apex Cloth Offset Issue While Importing. Tried lots Of Suggestions. (Using Maya For Exporting)

Hi, I have been trouble shooting my problem now for the past 3 days with no luck. i also read many of the suggestions here and elsewhere. I am simply reusing some of my created assets on a different mesh model. I did my best to completely wipe all history and hierarchy setups from the previous model and freshly apply apex cloth physics to the desired assets. I also made sure to export both the cloth physics and the mesh under the same scale settings (centimeters)
and yet i still have an offset when importing the apex physics to the mesh.

Maya - My Export Settings For Scene.
Export Maya.png

Maya - My Export Settings For Apex Physic. (individually exported per object)
Export Maya Apex.png

UE4 - Import settings 1
UE4 Import.png
**
Results**
UE4 Import settings 3 character.png

UE4 - Import settings 2
aaf286d384c42ab05d4593441a67997b8772b86d.png

Results
UE4 changed settings.png

UE4 - Import settings 3
f724938740b43f92d517aa0da9b8dcdc872b333d.png

Results
UE4 import 4.png

9a619bc45a225eef2093f1f5fde3f4bab61f3f4d.png

I have no clue how to fix this. I just want both assets using their apex physics to align naturally as Maya displays.

I Even tried deleting my maya documents and reinstalling maya. still nothing. :frowning:
I have literally ran out of ideas. I’m not sure if my binding method is to blame for this, but whenever i click “T0As Ref Pose” it changes something.

[update]

I deleted all possible history on the hair mesh. then I rebind the hair back to the mesh. then repainted the influences. then exported the Apex physics (in centimeters)…and still end up with the same result when importing. :frowning:
no clue as to what the real problem is.

Try deleting, resetting your bindPose node. You may have created an offset while binding.

sorry to respond late, i took some time off of my work. yes there was an issue with my bind pose, the hair specifically. it’s been fixed now. thanks for the response! :slight_smile: