Download

Anything I can do to stop foot sliding?

In the below video you can see a character I am using with the AI Behavior Toolkit. As you can see there is some foot sliding. I know nothing about animation so what can I do to sole this issue. Is there a simple fix for this? If not can you point me towards any videos that might help me solve this issue?

https://youtube.com/watch?v=AH4_6d0k6Ag

Use Root motion?
http://www.casualdistractiongames.com/single-post/2017/05/09/UE4-Root-Motion

I tried that. I even used a zombie pro pack that has a root animation folder. Put thos in the blendspace but I’m still having the same issue.

Screen Shot 2017-06-15 at 20.12.50.png

Screen Shot 2017-06-15 at 20.13.02.png

Is there any tutorial online that goes over this?

I’m still an animation noobie so I can’t help you OP.

That said I’ve seen this problem happening so many times in UE4 projects. Why is this such a common problem? Is it just that guys are noobie animators? Or is it a UE4 specific thing? I haven’t seen as much foot sliding in Unity.

Pardon my ignorance.

This happens when the character is moving faster than the animation intended. So, say your character is moving 1.5 meters a second, the animation is moving at 1 meter a second. There isn’t a way of automatically linking these speeds, so you have to do it manually.

You can either:
Play with the CharacterMovementComponent’s MaxWalkSpeed property until it looks right, or,
Change the PlayRate of the sequence in the AnimGraph.

If you did wanted to use RootMotion, you have to make sure two things:

1: That “EnableRootMotion” is checked in the AnimationSequence’s asset, and

2: That your AnimationGraph has RootMotion enabled… you have to set this from the Property Matrix in the Class Settings: click the icon with the little gear in it, and next to the search bar there is a button with a grid on it. Click that, and set the RootMotionMode to “RootMotionFromEverything”.

3: You will now have root motion from any animation providing it!

Of course I did a blog on this problem.

https://youtube.com/watch?v=K6yhmH06BWI

Root motion will solve the problem but has network issues so the brute force fix for skating using in-place is for x number of units the capsule moves forward you will need to pull the animations backwards to counter the constant forward movement I theory, as in I have not tried it, the movement should be stepped keyed and not a constant.
.