Download

Anyone facing iOS provisioning issues?

Hey all,

Is anyone facing provision profile issues?

Like am kinda stuck here. I know Apple apologised for their expired relations certificate.
So i’ve got it installed. Removed all traces of the earlier one.

Now i’ve also gone ahead. Generated a new developer certificate. And a new provisioning profile.
In the keychain, they all show as valid. I also copied them to the Engine/Build/IOS folder and also to my [PROJECT]/Build/IOS folder.

Now all this shows invalid in the project settings. What am i doing wrong in here?
Can someone help me, cos i m super stuck?

My developer certificate also shows as expired, which i generated just yesterday.
Also the date on the certificate shows for 2017-02-19.
What can i do?

All this is only in the UE4 editor.

Have you filled out your Bundle Identifier properly? (in project settings)

You did delete the expired ones?

After that try to import the cert and provision in the project settings iOS section. They should work after deleting the old expired cert in both login and system keychain.

Update Apple WWDR Certificate (Expiring 02/07/23) certificate from here: Apple PKI - Apple (and remove the old one from system).

I did all that.
I also edited my provisioning profile with the same set of certificates.
Then downloaded them and even placed them in the build folders.

WWDR Cert was the main issue (which i figured out earlier).
I have updated those too. Still no progress.
What to do?

Is your provision still showing up red in the project settings

Im also having the same issue, has anyone found a solution yet?

I had the same issue at the beginning of last week but updating the WWDR Certificate fixed it and all works as it should.

Also make sure you have the bundle ID set as the same as the one you created on the Apple Dev site (e.g. com.[CompanyName].[ProjectName])

Unreal seems to ignore time zones.

I’m not suggesting this is your problem but I’ve had this problem being based in Australia.

You can test the theory by overriding your time and date settings.

I generally have to wait a day until my certificates and provisioning profiles work after being generated.

Should you update the wwdr certificate in the packaging computer or in the computer you upload your app?

I deleted the old WWDR and installed the new one, still gives me provision key not found.

AFAIK the packaging computer.

Can you take a screenshot to see what you are getting?

https://answers.unrealengine.com/questions/339598/unreal410on-distribution-build-provision-and-signi.html

same issue as Bpop.

It seems you are right.

My developer certificate now shows fine.

Though my provision profile shows as ‘mismatched identifier’, so i’ll edit the provision profile and see if it works.

Can someone at Epic confirm, if this is a possible bug relating to time zones etc.

Wow that is a strange one if it’s true

It looks like the timezone thing got me too. I fought with it last night after creating the profiles and certs and went to bed without success. Built it this morning and everything worked right off.

Take it for what its worth.