Anyone else suddenly unable to build lighting?

It was working fine until maybe a week ago. Now I can’t build lighting. It gets stuck at “collecting the scene.” Even on a very simple map, it will stay stuck there and never make any progress. The Swarm window stays at 0%. I disabled my firewall and I still can’t build lighting. I’m going to see about rolling back Windows updates and see if that helps.

This was the problem: November 13, 2018—KB4467702 (OS Build 17134.407)

My computer downloaded it exactly one week ago.

I just uninstalled it, and the lighting builds are working perfectly.

thanks nath for reporting, how did you uninstall it?

Not even uninstalling that update i can build lighting i get Gathering scene and invalidating lighting forever,

Sorry Neongho. Sounds like you figured out how to uninstall updates: Windows Settings, Update & Security, View update history, Uninstall updates.

How long have you been unable to build lighting? I had the same issue you had, for about a week, which made me suspect the updates on 13 November. Maybe a different update broke your UDK. Did you get another update on 21 November? A different update on 21 November looked like it had similar known issues. Maybe that update is causing problems for you, and you need to uninstall both.

do you think it’s a good idea to uninstall all updates, ?

Probably not a good idea to uninstall all updates. But if you know when the problem started happening, you should be able to see which update happened on that day, and you should be able to uninstall one or two updates to get your UDK working again.

Game dev is hard enough without having to deal with this BS!!!
Windows-10 LTSB should be made available to all developers.
Anyone developing in UDK / UE4 using ‘airgapped’ Win10 rigs?

Unfortunately, an airgap isn’t really an option for me, as this is my only computer and I have to connect it for a variety of reasons. For several months though, when Microsoft kept forcing the Creators’ Update on me, I eventually purged my update cache, told Windows it was on a metered connection, and told it not to download updates on a metered connection. That’s the closest Windows will let you get to controlling your updates. (Note: That was the Spring Creators’ Update, apparently. There’s also a Fall Creators’ Update that Microsoft is foisting on us.) That Spring Creators’ Update was horrible. I basically couldn’t do anything with UDK: Making a prefab? Crash. Saving a file? Crash. Making a copy of an asset? Crash. Editing a material? Crash. I had to turn off autosave specifically because it would crash UDK every 10 minutes.

Windows updates also break Photoshop, by the way. I just don’t usually post about it here. It seems that every time Windows updates, it changes drawing pad behavior, and I have to go find a registry hack to set it back to how it used to be.

That makes for real sad reading Nathaniel…

I’m stuck with 2 end of life Win7 rigs, so I have to buy something in the new year or I can’t keep working. But what to do… I hoped if I waited long enough, there’d be more protests about Win10. After all, forced updates AND privacy violations at the same time. Where are the pitchforks people?! :stuck_out_tongue: Even if you install every Anti-Win10 spyware/malware tool and reg hack there is, all it takes is one rogue update to reset all your privacy safeguards back to zero.

Its unfortunate it took so long for Facebook to go into meltdown, as it might have been a real game changer for executives at Microsoft. To listen to the CEO preach on about privacy and human-rights! Even Microsoft’s Chairman is clueless versus the reality. I read a gem last week about a test of GDPR versus MS-Office from the Dutch regulator. Its now confirmed that users of Office have their sentences shipped off to MS HQ, just by using the backspace key…

WTF? Its Facebook / Google ethics everywhere!

I’m looking seriously at Linux… I’ve been using it for 2 / 3 years on older rigs so I could airgap dev rigs. But almost no one sells game rigs with Linux pre-installed. I only managed to do it before, because I didn’t have to deal with UEFI issues or Driver gotchas. But that’s not the case with new rigs! Plus if you work with Linux solely, who do you ship games to with a market share of 2-4%. Plus, it doesn’t really help with UDK dev at all. I doubt UDK runs well on Wine!

Ouch! - Tech is just so toxic at the moment!

lol that made me laugh, I agree with you forced updates are********(something wrong) now I can’t build lighting…:eek:

It’s because that I use only Windows 7 with automatic updates turned off. And I use a custom build of UDK Engine based on May 2011 beta, and the only problem I had was a crash on content browser because of a bug on windows presentation foundation font cache, which I solved by just turning off this windows service and cleaning the font cache.

Anyway good luck!

The people with these problems, what build version of w10 are you using? I’m right now at 1709(OS Build 16299.98) and is fine.I know that the builds of 16xx are fine too.Maybe downgrade to this and than block updates/set rules and disable that windows defender if you haven’t already.The only thing I have found here was that my dll didn’t wanted to save games, but widows gave me a pop up that gave me a hint that on windows 10 we dont have Microsoft .NET Framework 3.5, so I installed it and after that the Microsoft .NET Framework 3.5 service pack 1 and that fixed my connection between udk and the dll.
By default w10 uses framework 4 and up.Its stupid, but maybe reinstall from Microsofts page 3.5 and its service pack 1 to see if that helps with the light build?

I pay5 dollars who builds the light for me anyone interested?

I want to get rid of this nasty error.

Have you tried to build lights without using lightmass? I am not using lightmass on my game, Instead of it I am using a post process volume on which I adjusted the image saturation, gamma, brightness and contrast, to make it look a bit dark on the best UT3 Lighting Style :slight_smile: (UT3 did not have support for Lightmass)