Download

Anybody Successfully Packaging DLC in 4.17+?

Hey everyone,

I’m having a lot of troubles packaging DLC as a pak file for my game compatible with 4.17+.
I’m hitting a couple different issues being tracked by the developer team (Unreal Engine Issues and Bug Tracker (UE-42880), Unreal Engine Issues and Bug Tracker (UE-53636)).
However, it’s extremely surprising that packaging DLC isn’t working.
I can’t imagine there’s nobody packaging DLC for recent version of Unreal engine, which makes me think other groups have found workarounds.

Is anybody successfully packaging DLC in these Unreal versions?
Can you share your workarounds?

Thank you!!!

Wellp, I’m going to give this a wee hopeful bump because a little over a month later I still haven’t managed to solve this pickle…

Hello calembendell,

I was trying to see how a simple mod could work using the workflow by Tom Looman. But when packaging the mod from project launcher i could never get the game load the map.

I always get : Packaging a DLC Plugin Fails with “Couldn’t Update Resources” Error.

I see the mod pak file, i added it to my game pak folder, but never get loaded.

Are you using the version of unreal from the launcher too,or are you building from the source.

I am using the 4.18.3 version.

I still don’t have anything working.
Neither with the 4.18.3 build, nor with 4.19 preview, nor with source build on the promoted branch.
I’m working on the problem now.

I don’t have the engine build from source to check it but since you build it from source, have you checked the WinPlatform.Automation.cs file mentioned in this thread:

The code has changed a little since then, so the fix from the answers forum doesn’t quite apply anymore, I think.
However, you’ll find that even though the process is ending with an error message, a pak file will still be spat out by the system.
The process that is failing should not to my knowledge actually affect the final pak file.
Something else is causing paks to not load properly.

I’ve asked about it on the UDN a few business days ago, and I’m hoping to get a response soon :slight_smile:

Yesterday i noticed that this issue, UE-42880, was resolved. The target fix though is 4.20.

Thanks for catching that!
It doesn’t look like it’s made its way onto the promoted branch just yet, but I’ll check for it every morning until it does and I’ll let you know if it makes a difference with the overall pak problems.

Hi everyone,

I haven’t looked into this issue so I don’t have specific advice for how to address it, but If you need the fix from UE-42880 I can post it here.

it was fixed by calling WindowsExports.PrepForUATPackageOrDeploy() in BaseWinPlatform.Build only when not building DLC. The fix (CL 3909255) also renamed PrepForUATPackageOrDeploy to SetApplicationIcon to better reflect what the method actually does, which affected WindowsDeploy.cs, WindowsExports.cs and WinPlatform.Automation.cs.

WinPlatform.Automation.cs BaseWinPlatfor.Build() was:

[FONT=courier new] WindowsExports.PrepForUATPackageOrDeploy(Params.RawProjectPath, Params.ShortProjectName, SC.ProjectRoot, TargetConfigs, ExeNames, SC.EngineRoot);

and is now changed to:

[FONT=courier new] if (!Params.HasDLCName)
{
WindowsExports.SetApplicationIcon(Params.RawProjectPath, Params.ShortProjectName, SC.ProjectRoot, TargetConfigs, ExeNames, SC.EngineRoot);
}

Cheers,

Jonathan

Hello calembendell,

Have you managed to package a dlc/plugin?

Hey @Makis ,

Good news.
Try using 4.19 to package your DLC using the regular profiler method.
You’ll still hit the error at the end but the package itself will work well.
I am using a plugin developed by another gentleman to load the pak files at runtime.
I’ll talk to him about open sourcing it somewhere :slight_smile:

Great news calembendell!

Thanks a lot.

I will give it a try later.

Ah! Forgot something @Makis .
If you want to generate from the command line, you may find this project to be a good reference.

In this file: CharacterPluginGenerator/Program.cs at master · calben/CharacterPluginGenerator · GitHub
Find function RunBuildDlcPackageProcess.
That includes the command I’m using to build character packages.

Thanks for the tip @calembendell .

I tried a few simple dlcs yesterday seems to work with 4.19. I need to check again how multiple patches work together.

But still no no luck adding a mod from a content plugin.

I added a simple map at one point(not in the plugin content folder, in the main’s game content folder) and build a dlc like i was building a mod in profile launcher, without being a patch and i could open it in game.

But with this approach i couldn’t load a blueprint or any changes in a blueprint doesn’t work.

Thank you very much Jonathan, I was searching for this fix and it works! Looking forward to it being native in 4.20.

Thanks,
Testy

I did it with 4.19.2, launcher version. I have to say that settings on launcher profiles are quite confusing, and the reference is https://wiki.unrealengine.com/Modding:_Adding_mod-support_to_your_Unreal_Engine_4_project

Hi PatrickHC,

Did you manage to pack and load successfully the map from the mod or did you just made a patch for the game?

Could you open the mod example map in the Tom Looman’s project?

If that’s the case, could you please share the launcher profiles or how you made it work?

Hi Makis, mine is the same as the settings shared by Looman’s project, although I use 4.19.2. Please do compile the project via launcher, and compile DLC via launcher.

Hi Patrick,
Thanks for your reply.

I found it yesterday. I made new launcher profiles and totally forgot to enable the build configuration option.

Now it works with Tom’s project.

I will try some other projects too and try to make a simple plugin to read the mod name/info and load the map from a UI menu.

I will make a new post/tutorial about it when is ready and upload it to github too.

Hi! I am using 4.19. I am able to generate the APK app, but the DLC is generated only inside the /save project, instead of HTTPchunks folder. The HTTPchunks is created, but is empty. Besides, I cannot find the manifest file! Anyone can help with this please?

Thanks!

EDIT: To make it work with 4.19, you need to untick generate chunks from Edit - Project Settings - Packaging - Generate Chunks