Download

Any way to mute particular warnings in the logs?

I have a warning that spams my log files:



[0023.09] Warning: GetBoneMatrix : BoneIndex(65) out of range of ParentBoneMap for SkeletalMeshComponent_8 (feet)
[0023.09] Warning: GetBoneMatrix : BoneIndex(66) out of range of ParentBoneMap for SkeletalMeshComponent_8 (feet)
[0023.09] Warning: GetBoneMatrix : BoneIndex(59) out of range of ParentBoneMap for SkeletalMeshComponent_8 (feet)
[0023.10] Warning: GetBoneMatrix : BoneIndex(0) out of range of ParentBoneMap for SkeletalMeshComponent_8 (feet)
...


I’ve tried to address the issue, but without success. It doesn’t appear to have any negative affects on the game performance or stability, so I can’t really justify spending time resolving the root cause, and would prefer to simply disable the warning.

Does anyone know how I would do this (disable the warnings)?

defaultengine.ini


[Core.System]
+Extensions=mobile
//+Suppress=scriptwarning
//+Suppress=error
//+Suppress=scriptlog

those are removed with the suppress warning flag


Engine.ini
[Core.System]
+Suppress=Warning

beware, this will also suppress compile warnings!

although they need to commented out when compiling new code.

Thanks guys. So no way to only suppress this particular message. I guess this is one of annoying things about not having access to the source code.

Uping this post because I have exactly the same issue with one particular warning message in the logs.
Would be VERY convenient if you were able to mute one particular warning message.