Any version of UE goes black/flickers/glitches

Hello, I’m quite new to Unreal, I haven’t touched the program in ages.
Recently I re-installed again and after creating a basic project the engine seems to experience some heavy visual glitches that make it unusable.

After creating or opening a project in ANY version of Unreal Engine and hovering my mouse over any menu or properties, let’s say I click [settings] or [file], it’s supposed to open a window for that and show all settings.
Instead the window seems to duplicate itself inside that window before the entire program goes black and textboxes flicker and glitch across the screen.

I have looked online and tried updating/changing Nvidia drivers, compatibility mode, Run as admin, different resolutions and window sizes, etc, the problem keeps existing.
I have tried older and even the newest release of Unreal but neither fix the issue.

The viewport seems to work fine, I can move around the camera freely and look at models but any menu button makes the program completely glitch out and become unusable.

Screenshot below, taken while the problem occured.

There were threads in which people recommended to disable MFAA/FXAA in your nvidia driver panel. You could even try a studio driver instead of the game ready driver.

I did install studio drivers to test out of those worked better, even after turning off some settings in the Nvidia panel it still seems to give the same issues.
I’ve really tried looking almost everywhere and even asked friends who use Unreal.
I’ll double check on the MFAA/FXAA settings though but I’m pretty sure I turned those off.