Download

Any reason why "Convert to Static Mesh" gets rid of collision?

Hey,

This is something that bugs me a lot recently. I use a lot of modular packs from the Marketplace, where all the assets have their own proprer collision. I use those packs for a reason; I can do whatever mesh, buildings, house I want (pretty much). But as soon as I click on “Convert to Static Mesh”, the collision is gone and I have to manually replace it. And this is really, really tedious.

I can’t imagine that such a power tool like UE cannot keep the previously set collision. Or am I missing something? Like a little box to check? A plugging? Or is my workflow wrong?
What would be the point of all those modular packages if you need to redo 30% of the work?

you need to check bake physics data option when you merging meshes. But in 4.26 i have this problem too, all collision shapes are in primitive list, but there are not showing up in collision show mode and not working… in 4.27 all works as intended

2 Likes

Thank you for your answer. So I installed the 4.27 version and I could not find the options you mentioned in Convert to Static Mesh until I saw, a bit bellow in the Rick Click Panel “Merge Actor”.
So actually, I should not use Right Click ->Convert to Static Mesh, but rather:
Right Click → Merge Actor, ( I had no idea this option existed), because this one keeps the collision while the first…
Well, I don’t get the point of the “Convert To Static Mesh” anymore since I’ve discovered Merge Actor. It looks like Merge Actor is actually a Convert to Static Mesh, but way way better.