Any ideas on fixing a malfunctioning/broken (blank) Details panel?

Hello and thank you for taking the time to read this.

I am looking for some help. Yesterday while working on a project (specifically after importing an .obj file that I had created - although I do not think this is actually relevant to the problem) the details panel in the editor broke for me. The panel is still present, but it is not populating with anything. I will post a screenshot of what I am referring to. The panel is only broken for objects in the content browser. If I select a scene item in the outliner, the details panel functions as intended.

Here is some additional information about what I have tried and observed to resolve the issue so far:

  1. I have closed the panel and re-opened from Windows > Details > Details1, Details 2, Details 3, Details 4 but it didn’t help.
  2. I have tried several different engine versions. My project was created in 4.19 but I tried 4.20, and earlier versions as well, but the problem persists across all of the versions.
  3. I tried uninstalling the engines and the Epic Games launcher completely, and reinstalling on a new hard drive to no avail.
  4. Finally I have done all of this using not only my existing project, but with brand new blank projects as well as the provided template projects.

I was able to find some other posts that talk about similar problems but they mostly remained unresolved or didn’t seem to be an exact match for what I am experiencing. Any help would be greatly appreciated, I have grown very fond of UE4 and would like to get back to learning it!

Thanks in advance,


You haven’t selected anything the first picture. Isn’t this normal? Selecting content folder assets do not bring up details.