Download

Any idea what is going on here?

I had a project open and I saved it and closed the editor to restart it. When I tried to open the project again I kept getting this error at around 45%:

Fatal error: [File:D:/Build/++UE4/Sync/Engine/Source/Runtime/Engine/Private/ShaderCompiler/ShaderCompiler.cpp] [Line: 2066]
Failed to compile default material /Engine/EngineMaterials/DefaultVirtualTextureMaterial.DefaultVirtualTextureMaterial!

I can’t figure it out and can’t find any information about it any place. Nothing I do seems to fix the problem. I tried pretty much everything I could think of.

Did you use the beta Virtual Texturing API ?

Nope and it seems to be fixed. I have literally no idea what it was that fixed it either. I reinstalled the launcher because it had problems since the one update anyhow. When I loaded the project it struggled to open it at points. The progress would stall and the cpu would only be at like 4 or 5% usage. But eventually it ended up opening and seemed fine from there. I don’t have an old or under-equipped rig for this either. The project normally loads right up without an issue.

I just wish I knew what the cause of this was. Now I gotta watch out for the DefaultVirtualTextureMaterial boogyman LOL.

Defective sectors on HDUs, corruption on SSD, viruses/malware in the OS, issues with the PSU might all be possible causes.

None of those are the issue. I suspect the last launcher update had issues. Most likely it didn’t install cleanly. The problem I had has been seen before but rarely making it hard to reproduce or troubleshoot. But the solution for me was to do a clean install of the launcher to fix it’s problems and then open the project back up again. It doesn’t really help that the project I had issues with also happens to be my marketplace asset dump. I download new marketplace content to this project and it has a LOT of stuff in it at this point LOL.

Any idea what actually fixed the issue? Facing the same problem and nothing really helps.

I know that projects will hang at 45% some times while working on shader compiling and one of the build tools in visual studio can also cause the shader compiler to just hang around the 45% mark also. If you still have issues I would suggest looking into the issues caused by incredibuild tool if you have it installed. But basicaly just keep looking through issues where projects hang at 45% always seems to be a different cause for this.