Any Blueprint Infinite LOOP Detected // Project Destroyed?

Hey Guys!, i got an BIG Problem, i never had this before, i got an Engine Crash, and after restart if i want to Play on Editor, any Blueperints , like Construct/Pre Construct// any Call events get Infinite LOOP error on any created BP…, is this an Project Destroying Bug? …

tried like , Recompile everything, Deleting Saved/Inter Folder, Nothing helps…

Please HELP!


It’s an error in your code, nothing related to unreal.
You’re making something happen infinitely and you don’t let the frame finish.

Hello! Thank you for your answer!! I have no Extra Code
It gives me the Error for everything!
Like Infinity Loop in Construct’s, Button Clicked, on any Event !,
and i have no Extra C+ CODE!
i double checked all it gaves my for any Event in Unreal Errors!

and i dont use any Loops atm!

like here, IT Compiles Fine in BP Editor, but on Play in Editor it says here is an Infinite LOOP:. so im really scared about an Bug what Kills my Project totally! .

and its on my BP Actos aswell on any Event now! …
if i Delete the Unused Nodes, it gets to an other Random BP!, and on an Simple Thing like Button Clicked TOO!; and again i dont use a Loop or While LOOP !

open a empty map and set gamemode here:

So you can know if it’s something yours

and what is DefaultListRowFeature ??

There’s an option in the editor preferences to change the infinity loop detection. Default is 10000, I think. If that’s at 0, well then who knows.

done! - and override it to , so NONE as Gamemode, still same issue!
btw DefaultListRowFeature is just an Basic Widget.

thats my Current Setting!
and thanks to for your answer!

and just for Clarify, when i would delete the Both Events, and try to Compile same on the Next BP; also got it on Marketplace Assets what never got any Problem! ::

O man that is crazy, sorry, I don’t know what else it could be :sweat:

Okay was indeed a Bug.

Cromlech Studio 7:09 Uhr

Some other users have been reporting this, only work around is to start disconnecting flows in your BPs, running the game, then and seeing which node is causing it. Last user I saw mention it found out it was an event node (I think).

— ME : i just was reminding my last Created BP , indeed a Bug, i Recreated it and now it Works, Thanks 1000x Times Bro!

Works now, Thanks 1000x!

1 Like