Download

Anti-aliasing - UE4 4.7.5, iOS HOW ?

Hi All,
I moved my project from 4.6.1 to 4.7.5. /Because 4.6.1 has the problem with App Loader “No Architecture…”/

Now Antialiasing not working on the device, only in Editor and Mobile Preview are OK on Device AA Off :frowning:

I found these places with AA settings.

  1. Postprocess Volume / Misc = AA Method
  2. Project Setting / Default postprocess Setting = Anti-aliasing Method
  3. First Person Camera / Misc = AA Method
  4. Config / DefaultEngine.ini = r.DefaultFeature.AntiAliasing=0

What is the right combination for iOS? I tried almost everything. Nothing :frowning:

/UE4 4.6.1,PC, Win 8.1/ My functional combination for AA Preview/Device was:

  1. Postprocess Volume / Misc = AA Method= On, TemporalAA
  2. Project Setting / Default postprocess Setting = Off
  3. First Person Camera / Misc = Off
  4. Config / DefaultEngine.ini = r.DefaultFeature.AntiAliasing=0

Thanks

“r.DefaultFeature.AntiAliasing=0”
I’ve never touched this setting, but 0 is always “off” and 1 is always “on” for these types of settings.

Just a thought: Check your device profiles. You can do this in the editor through one of the windows, or you can do it through the BaseDeviceProfiles.ini found in your engine config folder. There you can set certain settings that change depending on what device you deploy to. So your iPhone, Android, and PC can have scaled rendering settings without you changing it one by one at build time. The default AA settings for iOS might have been changed by Epic.

AFAIK none of the post-processing AA options are available on iOS. There is a mobile AA flag, but it only works if you run your game on devices which support Metal.

Hi StephaBon & pedro_clericuzzi, thank you for your time.

I tried to change “r.DefaultFeature.AntiAliasing=0 to 1” but AA still does not work on the device:( / in DefaultDeviceProfiles.ini,DefaultEngine.ini in project folder, and various combinations-in editor… /
I tried clear New project, without starter kit, same result on deivice, no AA. But in iOS Preview is ok.

Testet on : UE4 4.7.5, PC, target iOS, iPhone- 4,4s,5s, iPad- 2,3,air same result at all devices.

PS: For Epic and Dev - Upload Error from Application Loader “No 64 support…No architecture find…” is SOLVED with 4.7.5 , only report “API is too large…” upload ready for review:)

Hi 3DA,

For best results for your iOS projects, here is thelimitations documentation for iOS development. it should help provide guidance on what will and what won’t work well in iOS and mobile in general.

Hope this helps!

Hi Wittlief,
Thanks for the answer, but still I have trouble with that./AA/ I do not see where I’m making a mistake. It works for some of you?
Thanks

I have same trouble with inis for iOs. On android everything looks perfect, on ios its just ****. Need some more digging into all that.

Thank you Nawrot for tried AA.

PS: My new app " Red Tent 3DA" , not a game !!!, not shooting !!! :slight_smile: Historical experience.
Two years I was looking for information and modeling.
Who is interested, I generate a promo code :slight_smile:

https://youtu.be/GqwJ4Inz4tM
https://itunes.apple.com/us/app/red-tent-3da/id978744393?mt=8

Ps:sorry for my ENG :slight_smile:

UE4 4.8, AntiAliasing, still does not work on iOS :frowning:

Adding the r.MobileMSAA value for each device works for me. Not sure but I think this may only work for metal.

Hi rckt26, thank you, but I still can not activate AA /tested iP5s, iPad Air/
Nowhere I have not found guide for iOS-UE4-AA :frowning:
Slowly I give up, within 3 years I did not grab the cycle where it would work. / when publish date :frowning: /

Hi, please see this question on UE4 AnswerHub, hope it helps.

Hi rranon,
Thank you very much. But still I can not turn AA on . I’m totally tangled :slight_smile:
Editor=OK
Device=no AA

clean scene/Project, no bloom, no special FX, only floor and box.

PC,UE4 4.8.1, 5S, iPad Air,

Hi All,
Now I completely reinstalled UE4, then installed a new UE4 4.8.2.
I created a new project.
I created a new C:\Users\PC\Documents\Unreal Projects\MyProject\Config\DefaultDeviceProfiles.ini
I launch on device /5S,AIR/
And AA works :))))
Thanks to everyone, I do not know where I made a mistake before.

DefaultDeviceProfiles.ini

[iPadAir DeviceProfile]
+CVars=r.MobileContentScaleFactor=2
+CVars=r.MobileMSAA=2

[iPhone5S DeviceProfile]
+CVars=r.MobileContentScaleFactor=2
+CVars=r.MobileMSAA=2

Do you notice any difference when setting r.MobileMSAA to 2 instead of 1?

Thanks

Yes, big difference

+CVars=r.MobileMSAA=1 On the device looks like without AA /Sharp/

Funny, I did a test and I got the opposite behaviour: no AA with r.MobileMSAA=2, AA with r.MobileMSAA=1. This with UE 4.8.2.

I think you are mistaking full device resolution (r.MobileContentScaleFactor=2) for AA (the effect is similar if not better in the first case, at least in my tests). Anyway, if it looks good and frame rate is ok, why bother?

Hmm??? I made a new test, still same result, iPad Air,5S, r.MobileMSAA=2 is AA on, r.MobileMSAA=1 is AA off.
(r.MobileContentScaleFactor=2) It was not mistake, I know about it. If you do not use the full resolution, you will have problems with Widget readability! Yes, it certainly will have an impact on frame rate /Terrain, complex scene …/.
it seems that every device has separate settings.
You testing AA on iP 6 ?

My last test:
65becc0897b7b1b250174a692b9e66ed20472bd7.jpeg

I’m not sure what the max is but I’ve actually been using r.MobileMSAA=4.

You’re right,rckt26, r.MobileMSAA=4 looks much better then r.MobileMSAA=2
4 is max, 8 no AA. I not measure Frame rate.