Download

Anti aliasing on android

I’ve made a game for android in unreal engine 4.8.3. It looks really good if a package it for windows and run it on my computer.
However, when I run it on android there is a lot of aliasing. The rest of the graphics looks fine, but I really wish I could make the lines smoother.

Is there any way of fixing it? I don’t know much about 3d modelling so there might be something I should do with the meshes to make edges smoother?
I’ve tried turning on TemporalAA, but I didn’t notice any difference.
I also tried adding r.MobileContentScaleFactor=0 to DefaultEngine.ini, but that didn’t help either.

You can see what I mean in the screenshots below:

Windows:
sswin.jpg

Android(open image in new tab if only part of the image is showing):
ssand.jpg

Hey Pesk92,

if normal anti alaising is disabled for mobiles, you could try to render the scene in a higher resolution by using ‘r.ScreenPercentage 150’. This means your game will be rendered in 150% of the max screen size. Another solution is to distract the user from the anti alaising effect by making the picture more lively. For example beside your farm house could be a working windmill, leaves could fall from the trees or some dust particle effects moving around.

Hope it helps

Hi Pesk92,

Antialiasing support for Android using MSAA is being worked on.

Hi,

Thanks for the replies. I figured out that if I turn on mobile HDR the lines looks much smoother:
ssandhdr.jpg

This works great on my high end phone, but it means that my game can’t run on a lot of devices. The optimal solution would be to be able to use DefaultDeviceProfiles.ini to turn mobile HDR on and off on different devices, but from what I’ve read that isn’t possible. Are there any way of achieving what I want here or do I just have to make a choice what’s most important for me here?

Unfortunately Mobile HDR changes the set of shaders cooked and included in the package so picking it at runtime isn’t an option. You may be able to upload a different APK filtered by device in the Google Play store, though (one APK for lower-end, another for higher-end).

Thanks. That is a good suggestion. Now I have another problem which is a bug with unreal engine I think:
On android 5.1.1, the game will freeze before it starts with a black screen if I’m holding the phone in portrait mode. It is the exact same problem as this. I posted this again as that thread seems dead. You can see a video in that thread which shows the behaviour. The bug does not occur in android kitkat. When do you expect to have a fix?

Thanks

This may be caused by an issue fixed in 4.9. If you check the AndroidManifest.xml generated in your project’s Intermediate/Android/APK directory after packaging you will see an android:configChanges line; it should be:


android:configChanges="screenSize|orientation|keyboardHidden"

This can be fixed in UEDeployAndroid.cs in the GenerateManifest function or you can try the 4.9 preview 2.

Thanks a lot. I checked the manifest and it is missing the screenSize part of that line. I’ll test this later.

Yes, it is fixed in 4.9

Where is the UEDeployAndroid.cs located in 4.8.3 installed through the epic games launcher?
Thanks.

Do you have to compile UnrealBuildTool from git? That is a lot of work for a small change in that file. Any way you could include this in the 4.8.4 hotfix? That would be greatly appreciated.

Yes, you’d need to use GitHub to make the fix. The file is in Engine/Source/Programs/UnrealBuildTool/Android. 4.9 preview has the fix in place.