[Answered] Code templates on XCode

Is it just me or when you go to “New Project” and select a Code template (e.g. Code Top Down) and create it, the XCode project is badly configured in a way that it doesn’t even run?

I tried running on the Mac and it didn’t start, saying “SBTarget is invalid”. As my intention is not to develop for desktops for now, I ignored that and went for what I wanted: iOS deployments.

I already have the Apple Developer account, and I have a few years of iOS Dev experience, so I know how iOS and XCode usually work. I’ve set up the developer provisioning profile and code signing identity. When I build & run the project on my iPhone 4S, Xcode installs the game on the device and runs it. So far so good.

But then, right after the default splash screen shows up, I get an alert saying “Failed to open descriptor file …/…/…/ (PROJECT_NAME) / (PROJECT_NAME).uproject” and the screen stays black forever.

I’ve tried waiting for several minutes, and nothing shows up. When debugging through USB, the game usually crashes. The console shows:

2014-03-20 00:45:37.005 TopDownCpp[2673:60b] No ue4commandline.txt [/var/mobile/Applications/A284EF19-C5F7-4CD0-93B5-5FAEC947B792/TopDownCpp.app/ue4commandline.txt] found

2014-03-20 00:45:37.011 TopDownCpp[2673:60b] Combined iOS Commandline:

========= This app is in LANDSCAPE mode

2014-03-20 00:45:41.905 TopDownCpp[2673:3c03] Initializing ULD Communications in game mode

Also, I’ve noticed that when you go to “Edit scheme…”, there is a missing target called _( PROJECT_NAME)RunIOS. That could be related to the issue, but I can’t confirm that.

Did anybody get these templates working on XCode? Or even, do these templates work on Visual Studio on the Windows version?


I was able to reproduce this with the Topdown code project. Apologize for the inconvenience but I was able to find a workaround until we resolve this issue.

  1. Build your ProjectEditor in Development
  2. Select Launch from Unreal Launcher
  3. Select your TopDown Code Project.
  4. With Device connected Click Launch > Select your device. (This will Launch the game on device.)

After doing this, I have been able to launch from Xcode with Debugging.

Nick Bullard | EngineQA | Epic Games Inc.

Awesome! I will try that and come back with my results. Thanks for the answer Nick.

Unfortunately, that didn’t do it for me. I’ve cloned the 4.0.1-release branch, generated the project files then ran UE4Editor in Development. After launching it from Unreal Launcher and selecting the project I’ve just created, I get this message.

Did I miss something?
Thanks again!

Sorry I should of been more clear with my steps. From a clean setup from GetHub, the first time you compile, you’ll want to just do UE4Editor. Once you’ve created your project after launching the editor once, you’ll need to build the scheme for you’re project, so in this case MyProject2Editor - Mac, and not just UE4Editor - Mac again. This will compile both the editor and your projects game module.

I don’t know if you got it solved @Werminghoff, but on a standard install (not compiled from Git) 4.3, this still goes bonkers end of July.