Download

Another Provisioning Error

(like so many before me, that this is laughable) I’ve completely run through creating fresh certificates, and provisions 3 times now. I’ve followed the instructions word for word. I get the replacement error when I try to import the provisions if I keep trying to import them.
I get errors like
LogTemp: IPP ERROR: Application exception: System.ArgumentOutOfRangeException: Length cannot be less than zero.
right after it says
LogTemp: … Provision entry SN ‘******’ matched 1 installed certificate(s)
LogTemp: … … Installed certificate 'iPhone Developer: Phillip Cook (
)’ is valid (choosing it) (range ‘02-Jan-19 *:: PM’ to ‘02-Jan-20 *:: PM’)

I even get .plist errors when making IPhonePackager.exe and what not.

There is a plethora of threads on this, some are slightly different from my situation, and the rest are not really resolved. I’ve duplicated the project, I’ve tried a blank project and putting them in right away with no such luck. I don’t have access to another pc, and I don’t have access yet to a mac (I’m working on a windows 10 machine). (If you’re wondering, I’ve made no codes, only used blueprints)

man, I’m using a free version of ue4, but I’d pay for customer support right now

My advice would be to start over with a fresh blank project and follow all of the quick start steps *exactly *and in the order in the guide. It’ll help you figure out what step you’ve done wrong, then you can go back and fix your project.

I have started with a blank project. I’ve also dug out an 8 year old decrepit laptop to try on there too. The guide says nothing about nomenclature, but is there meant to be any specific names that relate to the unreal engine project?

so here’s an update, I installed unreal on another computer, and it wouldn’t launch (even after a re-freshed install of windows), then I installed it on another windows machine, and only tried to bring the provision in, and it doesn’t show there either. Is this a joke? If I give someone my apple dev login, can you do this for me instead? I’m so angry right now!

The other thing, could it be a problem liked to my account? I may create a new account for this later

can I get some help here, or have this fixed in 4.21.2 PLEASE

iOS packaging is totally broken on 4.21.2 . Unreal should try to fix that rather than childish and useless battles against Unity

No it’s not, and this comment itself is pretty off the mark if you think it’ll encourage anyone to help you.

Try following some of the steps in the thread and see if you can find out what you’re doing wrong.

I’ve been through everything, made a new blank account for ue4, and it just doesn’t work on 3 different computers, I’ve followed every available instruction, and nothing, I’m also no the only one, there’s so many others that had this go un-answered. I’d pay for customer support at this point, but I feel that they don’t care much about their engine at this point with their lack of polish

Nope. It is REALLY broken. On my machine (macOS Catalina) the same certificate and provisioning working on 4.23 are not working on 4.21. I got an exception in Mono while loading them in Project Settings/Platform/iOS/Mobile Provisioning:


LogTemp: Running Mono…
LogTemp: Found mono via known Mono.framework path
LogTemp: Running installed mono, version: Mono JIT compiler version 6.4.0.208 (2019-06/07c23f2ca43 Wed Oct 2 04:52:23 EDT 2019)
LogTemp: /Users/Shared/Epic Games/UE_4.21/Engine /Users/Shared/Epic Games/UE_4.21
LogTemp: Executing iPhonePackager Install Engine -project /Users/Babele/Documents/Unreal Projects/Test421/Test421.uproject -certificate /Users/Babele/Downloads/ios_development (1).cer -bundlename com.fishbone.unreal
LogTemp: CWD: /Users/Shared/Epic Games/UE_4.21/Engine/Binaries/DotNET/IOS
LogTemp: Initial Dir: /Users/Shared/Epic Games/UE_4.21/Engine
LogTemp: Env CWD: /Users/Shared/Epic Games/UE_4.21/Engine/Binaries/DotNET/IOS
LogTemp: BranchPath = FishBabBoneBook///Users/Shared/Epic Games/UE_4.21/Engine/Binaries/DotNET/IOS/…/… — GameBranchPath = FishBabBoneBook///Users/Shared/Epic Games/UE_4.21/Engine/Binaries/DotNET/IOS/…/…
LogTemp: security: SecKeychainItemImport: The specified item already exists in the keychain.
LogTemp: IPP ERROR: Application exception: System.PlatformNotSupportedException: The FriendlyName value cannot be set on Unix.
LogTemp: at System.Security.Cryptography.X509Certificates.X509Certificate2ImplUnix.set_FriendlyName (System.String value) [0x0000f] in <bc69ad8632744cfba18f9705e53c6302>:0
LogTemp: at System.Security.Cryptography.X509Certificates.X509Certificate2.set_FriendlyName (System.String value) [0x0000c] in <bc69ad8632744cfba18f9705e53c6302>:0
LogTemp: at iPhonePackager.CodeSignatureBuilder.FindCertificates () [0x00144] in <ecbeb732c0b4477cb7878e21fc5b3594>:0
LogTemp: at iPhonePackager.Program.Main (System.String] args) [0x00653] in <ecbeb732c0b4477cb7878e21fc5b3594>:0


@Antidamage , do you have any evidence that iOS packaging works for 4.21? Does it work for you? If not, I would definitely say 4.21.2 iOS packaging is broken.

Yes, the evidence is that it’s working for everyone else.

100% of the time the problem is something you’re doing. Work around it by setting up a new project and going through the quick start guide step by step with a fresh profile and cert and learn the process.

If it turns out it’s a Catalina/4.21 problem then stop trying to run an old version of UE with a new version of Mac OS.

It is definitely not working for everyone.

On the current AR arch-vis project I’m working on, we’re about 3 months behind schedule due to iOS issues. We’ve had at least 5 months of iOS packaging hell, resulting in some changes to the source code to fix some of our issues. For example, Adhoc is broken at the source level, because the UE4 environment makes some incorrect assumptions about what a distribution certificate should contain.

One of the first AR projects I worked on using UE4 was back in May. They brought me on to fix their iOS issues because of my extensive iOS and AR experience in general, but by then the company had pretty much fallen apart, and I didn’t get a chance to really fix anything. So that project was actually killed because of UE4’s iOS issues.

This is not an Apple or iOS issue. All of our Unity projects are on schedule. All of our iOS projects are on schedule. None of them have the build issues that UE4 has. We’re all on Mojave because we don’t update the iOS during a final build cycle, and until this UE4 product ships that’s where we are.

I’m not super-duper happy about any of this.

-Chilton Webb

The post you replied to would solve your problem as well. The provisioning process is complicated until you’re familiar with what it’s actually doing. It’s just unfortunate that a complicated stage like building and packaging is also the first time you find out if your provisioning profile is working.

I faced all of this myself when I started out. “Not working period” is not a real issue.

The problem you’re describing with ad-hoc certs means you made a mistake either in configuring your project or in creating your provisioning profile. I’ve covered all of this in the stickied post. Try going through it, even the details that you think don’t matter.