Download

Annoying problem with Money Counter

My credit counter works perfect in Ver 4.15. but when I try to build up the same counter code in Ver 16.2

I run into the following trouble…

The credit counter won’t increment at all when picking the credits up off the ground even though the code to increment the counter
in the widget is there. I can pick the credits all up and play the pickup sound and destroy the mesh actor afterwards but the credit counter remains
always at 0. So nothing is adding up when I pick up the credits and I’m puzzled by this…

I checked in the designer to see if InCreditsText 99 counter text is checked as a variable and it is, so its not that.

I also get this following Blueprint Runtime Access None Error after exiting the play.

Error Blueprint Runtime Error: Accessed None trying to read property MoneyWidget from function: ‘ExecuteUbergraph_CrediPickup’ from node: Set InCreditsText in graph: EventGraph in object: CrediPickup with description: Accessed None trying to read property MoneyWidget

And this error is preventing the Credit Counter from adding up the credits when picking them up…

So I tried the IS VALID Node trick and that suppresses the access none error but if I use the Is Valid then the Credit pickup code goes all dead leaving the credits now down on the ground and can’t even be picked up.

So in Ver 4.16.3 picking the credits up works like it does in Ver 4.15, but the adding up code is all dead.

And I never got an access none error before in Ver 4.15 when I put in that Credit counter code. but I get it popping up when I build the same blueprint
code in Ver 4.16…

I don’t understand it, the adding counter code works perfectly fine in 4.15 but not in 4.16.

https://thumbs2.imgbox.com/ff/43/mhlVpuyO_t.png