I’m finding it a little annoying when basic data structures use terminology and method names which are different to STL.
[FONT=Courier New]FString::IsEmpty() === [FONT=Courier New]std::string::empty()
[FONT=Courier New]FString::Empty() === [FONT=Courier New]std::string::clear()
When I do [FONT=Courier New]if(myString.Empty()), I do not expect this to modify myString.
It would be nice if stuff like this lined up better.
However, I appreciate it is probably already much too late to do anything about this - and best names is something of a subjective issue anyway…
Sure I could just use std::string instead, but I’d rather not bring in those dependencies.