AnimNotify calling both run and walk at same time?

So I was really happy about getting AnimNotify to work on creating a walking sound in UE4 on default /mesh/animation/graph … however, when attempted to add a new set of notifies for running animation, walking animation is happening at same time causing doubled-up sounds.

To validate this, I added Print Strings to my notifies, one for each foot, and each animation. While character is in it’s “walk” animation, I was getting a print for run and walk at same time, but when I started running, only print for run notifies was happening.

So basically, it looks like while character is only using walk animation sequence, it’s blending in a “slow” version of run as well.


Would you be able to post some images of your setup so that I may try to reproduce this?



I’m getting same kind of issue too.

Notifies in animations:

Made a sound cue and duplicated it to a different name, to see if that was issue. It wasn’t.

And here’s a video of problem:

Hey MixitMan and Rehven,

I believe what you are seeing/hearing is a blending of notifies on both Walk and Run Animation Sequences. If you’re using a Blend Space to combine two, by default it will attempt play all notifies for all AnimSequences being run in Blend Space.

You can change this to only play notifies for highest weighted animation. In your Blend Space asset, open Anim Asset Details panel. Under Animation Notifies, switch Notify Trigger Mode from All Animations to Highest Weighted Animation. Now, only notifies of animation with heighest weight (viewable in Blend Space graph) will fire.

Hope that helps!

That fixed it for me, thank you .

Hi, I have same problem and although changing to Highest Weight mode fixed it, there is no sound between idle and walk when Idle is highest but there is still steps happening that would need sound. Is there a way to work around and exclude Idle state or something?

Hi G2Gmusic,

This is a very old post and a lot of functionality here may have changed. Also this user no longer exists. Please post a new thread in Using UE4 section or on forums.


That fixed it for me, too. Thanks a lot :smiley: