Download

AnimMontage plays but nothing happens

As the title says. The montage plays but the character never actually goes into that animation.

In the event graph:

If not playing -> Play the Montage -> Print if playing -> Is playing.

As far as debugging and the setup is concerned, everything works fine. Only thing is that I don’t see the animation play. This is a big problem because it means there is no way to debug montages. What do I do? I’m tired of fruitless guess-work.

And in the anim graph:

d39219cadd4231fe7733b7699eaa96e51400e6ff.jpeg

Would a better question have been ‘how to debug anim montages’?

Is the “UpperBody” slot linked within the AnimMontage itself?

Yeah it is

  1. try it without the “blend” node (just for testing)
  2. how do you play your montage? :slight_smile: (your setup in the character and anim bp)

Thanks for the reply, I have tried without blend node, no dice.

I will provide a few more screenshots. Excuse any messy graph, it’s because I’m still debugging.

This one here has an enum containing triggered animations that play in Montages. I have triple checked that it is being received properly and it confirms via the print node that it is playing the montage.

montage1.jpg

The montage itself and anim graph bypassing blend:

montage3.jpg

You have to add a “do once” between the branch and the “play montage” -> atm it plays the montage over and over again which will cause the character to “stuck” :slight_smile:

No luck and t doesn’t play at all rather than over and over. Montage plays but animation has no effect. Without debug nodes I would have no clue that it’s playing at all.

Here is how I setup the do once, is it incorrect and I’m misreading you?

Thanks for your help thus far.

montage4.jpg

Ok, forget what I said :stuck_out_tongue: It should also work without a “do once” node

e.g this is my setup:

f5cc1fbb1ca0d5fbe505e0694e6ef1b52298aa0b.jpeg

741e6fd486d26912e2f660fa9e5742a868ed5c3f.jpeg

055c7e9ce87a048918af155266fd31c6c87013cc.jpeg

I set up a simple example also and it worked… so I need to backtrack. Thanks for the help, I’ll respond back when I have something.