AnimInstance TryGetPawnOwner fails when PIE?

When the attached function (part of my AnimInstance) is ran with PIE from the AnimInstance’s tab it will both fail and succeed.

If I run PIE from any other tab the PrintString is never reached. When I run PIE from my AnimInstance tab it prints the string but my animation still seems to gets updated.

This was very frustrating because I couldn’t even debug the issue. I found the pattern just by chance.

Found an existing bug report for it, but its marked as Won’t Fix. At least I know its not just me. :slight_smile:

Hi CodeAnxiety,

This was marked as Won’t Fix because the preview instance is still technically running when you have the AnimBP open. Considering the workaround is to close the AnimBP, it does not occur in game, and is not a blocker it was not deemed significant enough to fix.

-Matt W.

I understand that. It makes perfect sense why its happening. :slight_smile:

However, given how much grief it can give someone who doesn’t know, like it did me, maybe you could just stop playing the preview when PIE is activated? It seems less like a bug and more like a user experience issue.

Considering that we allow users to work in the editor while in PIE or Simulate, it would likely cause more issues to disable the preview than to let it run. This is one of those cases where the means outweigh the ends.