[AnimBluePrint] Very Nasty Crash Pattern Making Editor Entirely Unusable

See bottom of this post for my emergency workaround that luckily worked, but I think this is a very very important issue for you to address, which is why I am spending so much time writing this detailed report, taking pics, and uploading my 383 mb project state (which was perpetually crashing)

Below is my original message before I found emergency workaround solution, I only found the solution after Rocket repeatedly and consistently crashing at least 50 times, within 30-45 seconds of launching Rocket with my project. (which is how I got to 50 crashes so fast).

Since the events of this message below I have been able to modify the asset in question and everything seems stable again, I explain my emergency solution at the end of this post

Dear Friends at Epic,

I have run into an utterly repeatable, utterly consistent, and totally unavoidable crash pattern when trying to use Rocket.

All productivity is stopped in terms of the editor, I have a window of about 30-45 seconds when editor loads before it crashes out completely with no log info. (I am using -log).

I literally cannot continue my project.

I also think I know pretty closely where the issue is, so dont worry :slight_smile:

My Entire Project Install For You For Debugging

And! I have zipped my entire project state and am uploading it to drop box for you all to look at and see if it happens to you too. (file is called VictoryGame.rar, under Nathan Lyer, and is about 383mb)

The exact and single asset that I feel is causing the crash is called:

WarriorAnimTree2 (AnimBlueprint instance)

Editor has been running absolutely smoothly for me till now, and I was using it all day today, until I did the following:

  1. I had 3 float variables added to my animblueprint, called




They are editable and exposed on spawn, and I put them in a category called “Foot Placement”

I have two Skeletal Control Nodes on my blueprint (cant send you pic now cause I cant load the blueprint, results in instant crash).

the LFIK variables were being put back together into a vector and used as in the input on one of the skeletal controllers, which was actively hooked into the anim blueprint output, and was working in-game, affecting the foot as expected.

This was fine, editor was fine for many hours

  1. Then just a few moments ago

I decided to add 3 more float variables to my animblueprint instance




I clicked them as editable, but did not make them exposed on spawn, also put them in category “Foot Placement”

I COPY-PASTED the vector-from-components node and the LFIK variables and deleted the LFIK vars, and added the RFIK vars, and hooked the result into the node, and hooked in the other skeletal controller node, officially adding the Right Foot controller to the chain.

So the left foot controller with its LFIK vars was connecting to the Right foot controller with the RFIK vars, and this was connected to node output.

There was a space transform thingie (the thing that is conveniently automatically generated when making skel controllers) before the Left foot skeletal controller and 1 after the right foot to transition spaces properly.

Then I exited the animblueprint, went to save, and Rocket crashed

Then I tried to reload editor, and it crashes now, every time it finishes trying to load my animblueprint asset.

I know this because,

if I flip through editor windows fast enough while assets are still oading

and try to load my animblueprint I was just editing, it crashes immediately.

And if I just let editor do its thing, it will crash eventually, once it finishes loading assets and trying my now modified blueprint.

So I tried to get through editor real fast and delete my animblueprint to stop the crashing, but Rocket wont let me delete it because it is in use by my character.

I tried logging off and Rocket did do the longer loading cycle , but then still crashes every time it tries to load my animblueprint

this is a very big problem

It seems entirely related to my animblueprint asset, not the editor itself, so I dont think re-installing will help.

I’ve listed the steps I did to modify my animblueprint into the endlessly crashing state.

Proof it is my AnimBlueprint causing the crashing pattern

I’ve also proven it is my single animblueprint that was modified that is causing the endless crashing, because I double clicked on the shootergame project and the editor loaded it just fine.

I loaded shootergame animblueprints and other assets just fine.

but then I switched to my project and it crashed upon trying to load my modified animblueprint

I repeat

The only things I did in the editor before saving, going from non-crashing to the endless crash-loop state, are the things I’ve listed above.



PS: Because I want to continue working on my project I have plans to try and delete my faulty animblueprint
but I have the zipped version of my unusuable project on my computer and uploading to you right now.

I was using -log to open the editor for at least 2-3 days
so there’s a whole bunch of log files that might help you out :slight_smile:


My emergency solution:

After trying various things, experiencing about 50 crashes (cause they happen within 30-45 seconds as the asset in question gets loaded, or instantly if I load the animblueprint directly),

on a whim,

or perhaps joyous inspiration,

I tried RENAMING the asset in question, BEFORE it managed to crash my Rocket for the Nth time.

So I frantically clicked through the windows of content browser, got to my asset (BEFORE it finished loading and crashed again), and I frantically typed in some letters (cause I only had a window of about 30 seconds).

Rocket very nicely told me that renaming the asset requires RECOMPILING THE BLUEPRINT.

so I said yes

and then…

and then…

well nothing happened,

Which was quite magical to me

after experiencing endless crashes within 30-45 seconds.

and now

all seems stable again!!


But this is a huge problem I have uncovered, it required fancy speedy mouse clicking finesse on my part to click through fast enough to rename the offending animblueprint before it crashed my whole Rocket again for the Nth time (pick any number it was extremely consisent, see the dropbox version I’ve posted).

More pics for you

The Emergency Solution: Renaming the AnimBlueprint and triggering Recompile

The Editor needing to do redirects, or not recognizing the file has been saved with right click, upon exiting Rocket

The Offending Blueprint as it was after I managed to rename it and recover it (after 50+ Rocket crashes)

Could you not just delete the offending asset and recreate it without the issue causing the crash? Obviously this needs to be looked into in terms of not being able to create such a bug but in the mean time it might get you working.

yea when I was watching the log when it was crashing the 50+ times, there was not info in log before crash , or as crash was occurring :slight_smile:

But I am quite confident it was that one asset, which upon renaming and recompiling fixed the entire issue :slight_smile:

Let me know if I provide any other info!

Thanks for UE4, I am having a blast!

Hi Nathan,

We were able to get the crash and a log of details. The issue is being looked into. Thank you for this information.

Until a solution is found, you may want to remove the offending uasset so you can continue working elsewhere on you project.

Thank you,


ooh nice! well I am glad my upload of project state has helped you!

Again my solution was to rename the asset before the crash could occur (window of about 30 seconds after each load), which triggered the animblueprint to recompile and removed the crash



Well I did get a workaround as I explain in the first post, renaming the animblueprint caused Rocket to recompile it, eliminating the crash behavior, so all is well :slight_smile:

Hi Nathan,

Do you happen to have the logs from one of the runs where it crashed?

Michael Noland

I’ve gone thru the crash reports for VictoryGame and can’t find anything that looks like the culprit, so it seems that it was crashing in such a way that no crashreporter uploads occurred.

I’ll see if EngineQA can repro with the uploaded project.

Michael Noland

Hi Nathan,

I was able to repro your crash with a debugger attached; it’s infinite recursion due to damaged pose links in the compiled animation nodes of that anim BP (the root points to a local->CS node, which points back to the root).

Do you know what you were doing in the anim BP the previous time you were editing it before the crashing started?

Michael Noland

Great to hear from you Michael!

I was setting up a series of modify bone nodes, and I had set up some variables within the blueprint connecting to the modify bone node inputs for vector data, and was constructing a vector from component floats.

The floats were variables created within the anim blueprint itself, as per a picture in my initial post.

Personally I think the critical thing is this:

I had selected the following:

  1. the 3 vars made in anim blueprint
  2. the make vector node with the 3 vars attached
  3. the modify bone node with the make vector attached

and I COPY PASTED this composition of nodes

then I linked the original modify bone node into the new pasted bone node (a copy of itself)

and the pasted bone node into the rest of the chain.

then I deleted the copied vars and made new vars to correspond to the right foot bone.

saved this

and this is when the crashing started

personally I think the copy-pasting action is what caused all the excitement