Animations with Z-axis motion

I’ve used a few animation packs so far both root and inplace animations, but it seems every Jump animation always has Z-motion which of course makes the player mesh move out of position of it’s actual collision in the character BP. Seeing as every jump animation I’ve seen so far in packs do this, I’m wondering if there is something I can do in the engine that eliminates their motion on the Z-axis? Whenever I disable root motion in the Animation Sequence it only applies to the x and y axis to keep the animations in place, while they still move around on the Z. I want the jump to be inplace so I can control the height of the jump in code.

I’m new to 3D, have more experience in 2D where everything is in-place on a sprite sheet anyway so I’ve having a hard time finding how to get these animations to behave how I want them to. Especially ones I spent money on for the fact they said they were inplace animations.