Animations messed up... Need help.. Stuck for 3 days

I imported my own Mesh to Mixamo that i created in C4D
Added the Pro Spell Animations pack from mixamo and downloaded the pack.
the animations look great on the character (both on the website and in persona)

i started a new 3rd person scene
Added the character mesh
added the animations targeting them to my new character.

Createda 1d blend. idle, walk, run
Created a Character BP
Set up inputs
created an Animation Blueprint
set up basic eventgraph
Set up a real basic locomotion state machine (just the blendspace for idle)
Set up the Default pawn class
targeted the animationBP and mesh from the Character BP


when i press play my character ONLY uses the animation for forward regardless of direction
(such as… if i pull back to walk toward me the character basically moon walks toward me)

When i go into the anim BP and go to the animation tab and click “Show Advanced Options”
and set the bones to Animation the animations look better… but the character runs away from the capsule
and the animation loop is noticeable while running around.

When i set it to skeleton the character walks around perfectly but the hips seem not move at all
like… the idle animation has a breathing effect but instead of the character moving up from the floor
the animation expands outward from the hips pushing the feet through the floor

ive tried everything i can think of… i cant figure it out.
i feel like its a root motion problem but i dont quite understand it… like i want this game to involve online multiplayer
and the documentation says you cant use root motion over a network… so im kinda lost and what i need to do.

Some Screenshots of your BPs would be great.
Moonwalk issue: you want the character to rotate to face you and walk towards you? Make sure to set CharacterMovementComponent to adjust rotation to movement direction.

Also you should combine what drives animation, for example root should always be driven by animation, I tend to have legs and arms driven by skeleton.

Also make sure you exported the mixamo animations as inPlace and UE4 Skeleton setup.

thats the best information ive had in 4 days.
I did NOT set them to “in place” and i did NOT set them to FBX for UE4

so… testing that out now… hopefully it works

[Here is a Video][1] of my workflow to recreate this issue.


i think i figured it out… i had to set the Yaw rotation to 540 instead of 360… i had to change the Boom and camera Rotations aswel as teh character controller rotation they were not right.

THEN… i had to set up a new Event Blueprint Update Animation because mine had _Copy after it and was not putting out information… it would also NOT let me rename it… i couldnt figure it out so i deleted it and copied it from the tutorial and it pasted in fine… no idea what that was about… seemed like a bug because there wasnt another one… but it said there was. wouldnt let me rename… but would let me paste in a new one that didnt say _copy without complaining about it… /Shrug.

Works now… thank you for the help…