Animations imported from blender not working correctly

I had a similar issue with my blend. In my case I had to set the import rotation to 180 on the y axis and set the uniform scale to 100.

In blender I had set the scale to be metric and carefully sized everything to match the scale of Unreal. This was a waste of time and effort since the import told me my mesh was too small and imported it backwards.

Hope this helps.

Everything (my animations) seems to work fine inside blender(2.72) but when imported to Unreal(4.6) everything just seems to get all messed up. It seems that I have the most problems with my back bones and my toe bones, they get twisted around their local axis about 180 degrees when the bones are moved or rotated when animating. I’ve gotten some of my animations to work somewhat correctly and I have tried different importing and exporting options. I did follow the CGCookie tutorial on armature (excluding some of the fine tuning features) so I don’t think there’s anything wrong with my bone hierarchy but there’s always a chance that I did something wrong, so here’s a picture of my hierarchy:

If someone could check if the armature hierarchy is okay I’d be really glad.

Here are my latest import and export options, there’s probably something wrong with these:

Oh and is there any difference between the Import All and Import buttons?
I’ve been struggling with this for a very long time now so any help at all would be greatly appreciated!

Thanks, but still not working:/ What way did your character face inside blender? Could this have something to do with the rotation there?

Not sure if this will work for you especially since I’m still a complete beginner in terms of using animations, but what I’ve been doing in Blender is set the rotation of the mesh on the Z axis so that the mesh is facing toward the -Y direction. Then I hit CTRL + A to “Apply” Rotation (I usually apply all 3 location, rotation, and scale to avoid any weird origin problems). I use metric units with my scale set to 0.010 to match Unreal.

Some thoughts, maybe you need to look at the rig setup you have for your skeleton in Unreal. If certain bones are moving in weird ways, then maybe the wrong bone was matched with the wrong node.

Thank you for your answer! But I still cant get it right by changing the rotation in blender, but I’m not quite sure about the bones matching with the wrong nodes, can you tell me how I can check/fix that?

I’ve only had experience retargeting animations to different skeletons, so my knowledge is mostly limited to the documentation I read here:

To take a look at how your bones are labeled inside Unreal, find your skeleton in the Content Browser and double-click on it to open its editor window (if you only see the mesh, check the top right of the window and you’ll see Skeleton>Mesh>Animation, and click on Skeleton). At the top of the viewport window click on Show>Bone Names. This will show all the bone names on your skeleton. If the labels seem right, then to see if you can straighten any kinks out try this: click on “Show Retargeting Options” on the left side inside the Skeleton Tree panel, and then right-click on Root or whichever is the highest parent for your bones, and select “Recursively Set Translation Retargeting Skeleton.”

If you want to look at individual bone and node matchups, click on Retarget Manager at the top toolbar. Select the rig you want (humanoid rig comes with the Engine Content), and you should be able to change the matchups. Your changes will save automatically. Hope that helps in some way!

My bones seem to be in the right place but I’m not quite sure if I want to retarget my skeleton though as this would mean I couldn’t use my own animations or am I totally wrong here? So I’m not sure if this is the best fix to the problem.

Yah I had the same doubts :confused:

Thanks anyway!

I think I found the answer so I’m just going to leave it here if it helps other people. It turns out my roll values for the bones were wrong…:stuck_out_tongue: I still have no clue why some of the animations work somewhat correctly with the old roll values though.