Download

Animations imported from Blender are smaller (0.1 scale)

I’m trying to export animation for my fps hands, but they appear way smaller (0,1 scale of actual mesh to be precise). UE4 keeps throwing “Imported bone transform is different from original” warning during animation import

  1. I’m exporting the mesh itself and animation from the same scene form the same .blend file (I literally just check “Bake Animation” option in fbx exporter and export the same mesh again with animation). So they have the same scale settings
  2. The armature isn’t named “Armature”, I renamed it and it didn’t do anything
  3. I’m using skeleton form the original mesh on import, not creating new one

You actually have to set the blender scale before you do work on anything.

You can try to “hack” a working solution by importing at a scale of 100, but its pretty much going to be bad no matter what.

Best advice is you set up blender correctly and start over.

What exactly do you mean by “set up blender”? My units are fine (0.01 cm in world settings as it should be according to forums) and export settings are set up correctly too (if people on forums are correct)

Sounds correct.

So then, why do you need scaling when you export/import?

Are you importing the skeleton too (leaving it blank to get the correctly scaled one in?)

Found the problem, I needed to apply scale on the armature. UE4 wouldn’t work with non-one scale even if the skeletal mesh itself has the same scale
Luckily, I wasn’t too far and had to fix only one animation

1 Like