Animations go blank

This keeps happening now, where I’ll copy in an animation (uasset file), set a skeleton for it, and then as soon as I hit save, it goes to a default static pose.

I’ve been using UE5 for a few months. I’ve brought in animations in this way before. I’ve tried different anim files from different packs and it’s doing it repeatedly. I don’t recall changing any animation related settings and I’ve tried in more than one project. Any ideas?

Okay I solved my problem, which happens almost every time right after I post about it. :grinning_face_with_smiling_eyes: I’ll leave this up in case anyone else runs into it.

In the animation, I go to Additive Settings and set Additive Animation Type to either Local Space or World Space, and the animation will work again. Thing is, I don’t remember ever touching that before :thinking: nor do I understand why it is needed now.

1 Like

Amazing, thanks for posting the solution! I ran into it a fair few times as well. Mainly pops up when anim assets referenced a local UE4 Mannequin, and I then retargeted it to the starter content mannequin.

I found in some cases Additive Animation Type isn’t appropriate. One in particular I have to Export > Reimport (to fix Z translation) > then it stops, and it’s one that can’t be additive. (If it shrinks or disappears that may be why.) So in that particular case…

A solution is to export + reimport with “Use Default Sample Rate” (samples all animation curves to 30fps) under Import Settings. Then additive type can be no additive again.

But, that may not work for all. I have others it doesn’t work for.