Download

Animations From Blender All Have Same Weird Bug

I’ve made two different models in Blender following tutorials on animating, and then export/import options, but all of my animations have a weird bug when in UE4 where a limb, usually the foot or leg, just goes off course and jitters out of place for a couple of frames. It runs perfectly smooth in Blender and in the first model I made, I was able to get them to stop in UE4 after hours of trial and error and adjusting the number of frames the animation was, the export/import settings, and other things… but I never really figured out a repeatable remedy to it. In my second model, I can’t get them to go away at all, and I was trying for 6+ hours and looking up information to find SOMETHING that could be the cause of it. So now I’m here, hoping someone has ran into the same or similar issues and found a solution?

No, if you look at the top right you can see my armature hierarchy. My Root is the first bone of my armature. I don’t know if Armature being under Armature is normal or not? I assume it counts animations and armature as subcategories of the whole armature.

not the first bone, the entire armature… i’ve never had this particular problem with a all blender anim, but just give it a look… :slight_smile:

I SOLVED IT. Days of trial and error and speculating :rolleyes: If anyone else runs into this error, you have to set your Blender’s frame rate to 30 FPS. It defaults to 24 FPS, which is why if you take your 19 frame animation into UE4, it changes it to something else like 23 or something. It was changing the length of all of my animations from what they were really in Blender, which I didn’t think meant much, just a translation thing… Well, it means everything lol… After setting Blender to 30 FPS, and exporting both the Skeletal Mesh and then Animations with that set, the animations in UE4 match that of Blender’s. I thought I had tested the 30 FPS thing before though, so there may be a combination of other settings that I’ve used in the Export/Import process that fixed everything up, but for that, just follow tutorials on Youtube and most have the proper settings. Hope this helps someone else who runs into this issue! Seems so simple, but ughhhh. lol

1 Like