Animations exported from blender stack strangely based on sequence in "Action Editor"?

I’ve got a single Blender file that contains my mesh and all the animations associated with it. When I export the animations, they stack strangely based on their sequence in Blender’s “Action Editor”. Basically, any bones that are untouched in an animation take the initial key frame from the animation listed before it in the “Action Editor”. Is there a way around this? Should I be using a unique file for each animation?

this is great! thanks, lukors!

As I understand from watching the blender support live streams, you should indeed be using unique files for each animation. So you’d have one file that is just the skeleton with no animation, and then each animation would be imported as separate files. When you import the animations, make sure to uncheck “Import Mesh” and select your previously imported skeleton in the “Skeleton” drop down.

By the way, here is the support stream video in case you haven’t seen it, it has loads of great information: Blender & UE4 | 01 | Live Training | Unreal Engine - YouTube

hey, lukors. it seems i’m almost there, but i’m getting an error when trying to import an animation. here’s what i’ve done:

Rigged a skeletal mesh in a single blend file. Scene looks like this:

Then, I created a new blend file, “Linked” the original skeletal mesh file and make it a proxy. This allowed me to edit the pose and create an animation. Scene looks like this:

Then, when I try to import the animation fbx into Unreal, it looks like this:


I get this error upon importing:

Any ideas?


FYI…I don’t think exporting animations is working using the FBX 7.4 settings w/ Blender 2.73. Still borked. I reverted back to the 6.1 exporter and things are starting to clear up, though it looks like Blender is monkeying with bone names when exporting animations in a separate file and it doesn’t find matches for the bones on the skeleton i’m importing the animation on to.

TLDR; Blender still not fully supporting the skeletal mesh and animation pipeline for UE4 :’(

So it says that the root bone does not have an animation track, have you double-checked that the root bone does indeed have animation data?

If that doesn’t solve it, I would suggest trying to make a copy of your rig file instead of linking and making proxy, just to make sure that the proxy thing doesn’t create any problems.

If that doesn’t solve it, compare your structure to the one in the file they gave out for the support stream, it can be downloaded here: Support Stream – Blender Animation & UE4 – Jan. 13th, 2015 - Announcements - Unreal Engine Forums

Try to get that one working just to see that it CAN work in the first place, I managed to import that skeleton and created an animation for it that imported correctly in UE4.6.1 and blender 2.73. When that works, compare your files and try to find the problem that way. I would compare it’s structure to yours myself, but I’m in school right now, maybe I can take a closer look when I get home if you haven’t solved it by then.

so, i tried importing that skeleton with same settings as the tutorial video and looks like it mostly worked, but notice the right foot is borked below. i’m using a UE4 build that was synced from the promoted branch 3 months ago (i think around 4.7) and Blender 2.73a, so maybe that’s the problem :confused:

i totally appreciate your support, lukors! TBH, what i’m doing right now is all prototype work and using the Blender 6.1 exporter gives me zero problems so i’ll probably just use that until i can switch to a proper Maya pipeline.

I have the exact same problem with the right foot, I just accepted it. :stuck_out_tongue: But anyway, does it work other than that?

welp, i’m unable to export animations. the same exact blender file using the 6.1 export brings the animations along just fine. i’ll probs just use 6.1 export for prototyping. bah, well.