Animations are not playing properly in viewport?

Need a bit more information, but from what I can assess, is Bored the first animation in your Asset Browser list while attempting to preview the animation in the Animation Editor? If so, just clicking once on each animation to preview it will not work.

You simply have to double-click each animation in the Asset Browser to preview and tweak its values:


If you’re referring to the animation thumbnail that pops up when you’re hovering over it in the Content Browser, then that just may be a bug.

Hello there, I currently have an issue with my Unreal project. My animations are still playing perfectly fine in the blend spaces as well as while testing the game as it’s running, but whenever i try to preview an animation from my content browser, they are literally all the same thing, they all just do the Bored animation, every single one of them including my attacks, weapon draw, pickup jump etc… This is extremely frustrating since Id’d figure a little bit of digging in the menus would allow me to find a fix for this but to no avail :(. I tried re-importing the animations and importing new ones to test if this fixed it, alas to no avail either. Am I missing something? This happened as soon as i started importing animations for another skeletal meshNPC. Thanks for the help!

First off thanks for the quick response, sorry if I’m not making myself clear, so ill try to be as precise as possible. Wether it’s from the animator editor, the content browser, and wether i click or double click any of the animations from any window, they all play the “bored” animation which is indeed the first animation in the list for that skeleton’s abimation, furthermore if its of any help, my montage’s are just one glitchy mess of a constant spiky animation, strangely they appear completely normal"workin correctly" at run-time inside the editor. Hmmm… Any help is greatly appreciated :smiley:

P.S the animations on another of my skeletons appear completely fine at run time and in the editor 0_0

do u solve your problem? i have the same problem.AAAAa its horrible

Reimporting my mesh solved my problem