Animations are messed up.,. need help.. stuck for 3 days

I imported my own Mesh to Mixamo that i created in C4D
Added the Pro Spell Animations pack from mixamo and downloaded the pack.
the animations look great on the character (both on the website and in persona)

i started a new 3rd person scene
Added the character mesh
added the animations targeting them to my new character.

Createda 1d blend. idle, walk, run
Created a Character BP
Set up inputs
created an Animation Blueprint
set up basic eventgraph
Set up a real basic locomotion state machine (just the blendspace for idle)
Set up the Default pawn class
targeted the animationBP and mesh from the Character BP


when i press play my character ONLY uses the animation for forward regardless of direction
(such as… if i pull back to walk toward me the character basically moon walks toward me)

When i go into the anim BP and go to the animation tab and click “Show Advanced Options”
and set the bones to Animation the animations look better… but the character runs away from the capsule
and the animation loop is noticeable while running around.

When i set it to skeleton the character walks around perfectly but the hips seem not move at all
like… the idle animation has a breathing effect but instead of the character moving up from the floor
the animation expands outward from the hips pushing the feet through the floor

ive tried everything i can think of… i cant figure it out.
i feel like its a root motion problem but i dont quite understand it… like i want this game to involve online multiplayer
and the documentation says you cant use root motion over a network… so im kinda lost and what i need to do.

Usually I set my root bone to “animation”, hips/pelvis to “animation scaled” and all other (remaining deform) bones to skeleton.

that didnt work
same result

it ended up being a combination of i exported from Mixamo without “in place” selected and i didnt export to UE4 FBX… only FBX
Then… I had to set the rotation in the character controller.