Download

Animation WORKS! Morph Targets NOT imported?

Hello All,

Yeah, I’m still fighting with the .FBX madness…

As you can see on the video example, I’ve successfully import the animated key-frames.
BUT the shape-keys (morph targets) are not appear on UE4 after import.

I want also the key-frames morph targets to PLAY on UE4 when imported.
Can somebody please explain me how to fix it?

Video example of the problem:

https://www.youtube.com/watch?v=zVhjli-02SM

I have imported animations and morph targets but I hadn’t tried an animated morph target before but I gave it a go and as you can see in this gif

[SHOT]http://i1277.photobucket.com/albums/y487/smokey13A/animated_morph_target_zps9xpfzy5z.gif[/SHOT]

I managed to import it and it works(ignore the model and how bad the morph is, it’s an old test model:)), I used the default settings during export from blender. maybe yours isn’t working because the morph target and head motion are in 1 animation, have you tried doing it as 2 anims, 1 for the mouth and one for the head movement?

even if the morph anim didn’t work I would have thought that the morph target would have at least imported with your mesh.

they is a tick in import avanced options on unreal, and another in the fbx file when export… both checks.

Thanks for the reply and example smokey13, it seems like you got it to work!

My example is only 1 shape-key for the mouth (open / close) the movement is just a key-framed rotation, no morph.
It looks looks like your example: basis + key 1

The reason I do this simple test is before I’ll start work on a full original character with armature + shape-keys + full animated sequence. so I just used the Monkey for easy testing.
The main idea is I want to get a character fully animated in one export on 30 FPS so I can also add the music to match in UE4.

Can you please also try a short test and see if you can get the character to move or rotate + morph at the same time?

Thanks ahead! :smiley:

  • Sorry about my bad English.

The problem (for a noob like me) is that there are too many options, and even after watching the twitch video I’m still confused.

I’m wondering how the awesome guys from EPIC grab all the key-framed animation sequences for the “Kite-Demo” or any other cinematic demo to just PLAY, there must be a way to do it… and I already got 50% of it to work, but not the morph.

Wouldn’t you want to use Matinee rather than Persona-blueprint driven animations?

I think with Matinee, you can export and import a fbx file into something like Blender and then animate in Blender, then bring the fbx back into Unreal and the animation will just play.

I didn’t realize that I need to import to Matinee, I thought that I need to import to the “main” UE4 editor like I did in the video, and than I could use it on Matinee… so do I need to import somehow from Matinee and skip what I did on the video?

Yes! I think that Matinee is the main focus where I should animate a cinematic with any character I will bring to UE4.
But, I my goal is to do all the animation in Blender (complete animated sequence) just like in my shot test in the video (Monkey Lip-Sync).

So… I’m a bit confused now, because 50% worked… I mean, the animation of the mesh worked but only the morphs failed or maybe there is an option I just need to check or enable in order to make the morphs work.

So, I may be mistaken, but a morph target is simply an instantaneous snapshot of a set of vertices, no?

You could import the skeletal mesh into the engine, but you’d still need to key the morph target within the engine. I’m not sure if the fbx import would bake the morph target information into the animation.

My understanding is that you’d want to import your skeletal mesh into engine, then export out of engine using Matinee, then animate in Blender, then reimport into UE4 as a Matinee sequence. That way, the sequence would simply play as a movie animated using keys directly from you software package.

done:D

[SHOT]http://i1277.photobucket.com/albums/y487/smokey13A/morphing_monkey_zpsdefvdbgi.gif[/SHOT]

I have only done a basic test but it seems to work, haven’t had much time to workout the proper workflow yet.

your English seems fine to me:)

Alphanumber, I’m not an expert but I think yes, I would say the morph targets (so called: shape-keys in Blender) are a different versions recorded of vertices, so the number of vertices of the mesh are not change but only their location.

I didn’t try to key the morph targets inside UE4, and I bet it will be easier just to do it inside the animation software (Blender in my case). BUT! if it’s the only solution I should try to do that.
Still, I didn’t see any morph-targets when I imported as seen on the video example, so the main problem is that the import didn’t “SEE” the morph at all… I did something wrong, that’s for sure.

I have no idea how to do that, but it make sense… well it sounds very complicated and forward > backward export import… not really friendly procedure but if this is the only way to make a cinematic in UE4… I’m willing to try hard (I still have no clue how to do all that).

Wait a sec… what sorcery is this??
I think that smokey13 (the awesome!) just got it in the most productive way well… it looks like it!

smokey13: **THAT’S IT!!! ** :smiley:
I’m not sure what you’ve done because there are SO MANY OPTIONS to check/uncheck when export and import from Blender to UE4.
It’s very confusing for a Noob like myself, that’s for sure.

1 - Can you please make a short a step-by-step video just to show what you’re doing in Blender and in UE4 to make it work?
I’m sure it will help also to other confused users like myself in the future.

2 - If I want to add the AUDIO I used on Blender (for lip-sync 30fps) will it work also in UE4 ?
(make the monkey sing in 30 fps inside UE4 is the ultimate TEST for my goal)

if I get this to work… it will be AWESOME!

no sorcery, I’m just not bad at experimenting:p

I am not sure what I did either;), although I exported using the default blender settings and just ticked the relevant settings during import.

unfortunately my laptop is kind of dying so I cant record a video, instead I think I am going to remake my test file(its a mess right now) and then I will write a quick step by step post, I will also add the re-made file to the post for you to download, we may need to find some workarounds but I think it can be done.

you will probably have to keyframe the lip-sync movements and import both that animation and the song into UE4 and then make them play at the same time using matinee or a Blueprint.

agreed:)

YAY!! I’m very curious to learn how to make it work! and I bet more people will be interested in the workflow.

That’s originally what I’ve tried to do with the video but I didn’t even got to the Audio part because of the problem that the key-frames for the morph (mouth shape-keys) didn’t work…
But once it will work I will try the next scary stage of: Matinee + Bluprint in order to make all fit in 30fps !!!
I have no clue how to do that and when I messed with Matinee I got lost right away… so I should wait for your tutorial and following the step-by-step in order to get the idea.

Thanks ahead for your time and patience, I appreciate it a lot! you’re awesome :slight_smile:

UPDATE!

Hey guys, I just wanted to update you after many hours of messing around trying to figure out what was the problem.
The good news: **IT’S NOW WORKING! ** :smiley:

I’m not sure if that’s the ultimate answer to: “problem solved” related to this subject because it’s just one test I did with this simple Monkey mesh animated and nothing complicated.

OK! so what was the problem and how did I solve it?

Goal:
Export animated sequenced with key frames of rotation and shape-keys (morph targets) from Blender 2.73 to UE 4.7 on 30fps.

Problem:
Importing to UE4 only key-frames of the animation (rotation in this case) works, but NO MORPH-TARGETS, UE4 don’t show the morph targets or play it in animation.

Solution:
It seems like when exporting the .FBX and select: Applied Modifiers didn’t work because Blender won’t allow to apply a Subdivision Surface modifier (to smooth the low-poly object) and that might cause a problem to ignore the shape-keys as well.

So in order to solve it, I just DELETED the subsurface modifier, and tried to export again.
This time it worked!

I hope that it helps anybody like myself who ran into this situation, I’m sorry for my bad English.

And now I’m going to try to solve my other problem, but that’s for another thread… you’re welcome to follow my insanity if you like and we can all learn new things in UE4 and cinematic / animation related issues. :slight_smile:

well that saves me some time, glad you got it working:)

you should apply the subdivision modifier before setting up the shape-key.

Thanks! well… you can always try helping me in my next step: on this OTHER problem](https://forums.unrealengine.com/showthread.php?63251-Limit-Animation-Actor-Cinematic-to-30-FPS-How) :wink:

It may be easy to solve but I have no clue since I’m totally new to UE4.

The guys who have this working, can you post a screenshot of your Blender setup. I just try to do this for the first time and animation is only 1 frame and the anim model is flipped by 90 degree. Can you also include a screenshot of your rigged model, since there are different ways to do this.

Update
If you set -Z up in Blender export panel the anim model is aligned correctly. But there are still issues…

Sure thing here is the setup I used:

Blender_FBX_Setup-1a.png

The thing is, I just wanted to TEST the shape-keys (morph targets) export > import, Means there is no armature at all (Bones) in this. I used the default Monkey mesh and created a quick shape key for open/close mouth.
Just a mesh + key-framed animation (I manually animated the lip-sync for the test).

You may want to play with it, for example try the Smoothing: Edge see if it gets better results on UE4.

I hope it helps. :slight_smile: