Download

Animation timing is off when imported (from 3DS MAX)

Hi, I’m new to the whole process of importing animations to UE4, I also have a very basic knowledge of 3DS Max, so this is probably an obvious mistake, but I can’t find where I’m wrong.

I have a simple animated tail that bends from left to right, perfectly looping in 3DS Max, however in UE4 I got a clunky animation, it seems like it stops at some point and then resume, also the timings are off, I mean, the animation speed over time.

I’ve tried to attach a video showing this problem but its too large for the attachments on this website.

Also, just for reference, this is a pic of what my 3D scene looks like in 3DS Max:

b317548107426303776c6a3e27d01f5d4568755c.png

Any help is appreciated.

Thanks!.

Hi!

You have activated Bake Animation option in FBX Export dialog?

Look this tutorial about export animation from 3DS MAX to UE
https://youtube.com/watch?v=H3SCSPmKXCs
https://docs.unrealengine.com/latest/INT/Engine/Content/FBX/Animations/index.html

No, didn’t bake the animations in the export panel, should I?.

I will read that document ty.

Yeah i had problems with the animations not playing properly until i had checked the bake animation box

The bake animations didn’t solve the issue, it still happens, this is what I see in persona, maybe there is something wrong:

did you import it fresh or reimport?

Fresh import. I can even tell you exactly the steps, it’s really simple what I do.

Only thing I can think that isn’t always obvious with Max exports is, make sure you don’t have any key frames outside your active range. Even if you tell the exporter to only export active range, it will in fact export any key frames you have, so check for and delete any keys out of range.

If you look at the picture I attached, there is a segment of the animation that is empty, and I noticed that the animation “jumps” exactly at that moment. I’m sure I’m making some obvious mistake, just can’t find it.

Hi.

Hard to figure out without seeing what the actual problem is.
But in 3dsmax your animation is 80 frames and in ue4 your animation is 6 frames. Why?
Did you skip frames? Is your animation actually only 6 frames?

The animation is 80 frames with 5 keys, just as it shows in the OP. I’m kind of new to persona, but if those gray rectangles represent a single frame, then there is something wrong. It seems like those rectangles represent each key frame maybe?, plus 1 that is. No idea.

I fixed it, I ticked: “resample all” in the export dialog, last option in the animations section, and now the animation is correct.

Thanks all.