Download

Animation Shaking After Importing?

I have created a walking animation where the head moves smoothly back and forth during the loop.
However, after importing the head shakes like some kind of silent hill character after importing.

In 3DS Max the animation does not show this behavior, only after importing it into UE4.

Here are two GIFs showing the issue:

(Note that it is much more pronounced ‘in person’)

This has not happened for my running animation, or any other animation I have created. Just my walking animation.

Any ideas on what could cause this or how I could fix it?

Thanks!

This is most likely an exporting issue. Quick way to make sure is to import the FBX to Max, and see if it also shakes like that.

With possible exporting issues like this the first thing I always do is try one setting in particular, on the animation settings of the exporter. There’s a check box, from memory, I think it says Generate Key Per Frame. Not sure of the exact wording now, I don’t have Max open. So if it’s currently un-checked, try exporting with it checked. If it’s currently checked, try exporting with it un-checked.

I’m not saying this will definitely fix it, just the first thing to try and see what happens.

Check your root placement, if your root is in the hips then your hips should be at 0,0,0 in max both in figure mode and animation mode before export.

Had some time to come back to the issue.

3DS Max is definitely exporting it like that. Because when I re-import the FBX into Max I get can see the shaking.
I have tried some of the obvious option settings like baking and all that. No dice yet. I also found another animation it does it on.

EDIT

Okay, only for SOME animations when I reimport them do I see the artifacts in 3DS Max. Others are fine in Max on reimport but shaky in UE.

This is going to be a rough week… lol

EDIT 2

So, it turns out you can smooth the high frequency jittering by baking the animation with a sample step of 2 instead of 1. Obviously you lose some fidelity, but at this point I’m happy enough.

Also, it seems like my issue is similar to this issue:

for what it’s worth.

Anyone found a solution to the problem yet? Think i caught the same symptom you’re having [USER=“79416”]Pumpy Bird[/USER] , only its in the hands instead of the head.
[video]https://i.gyazo.com/d13e939e9378cd0a48063e657eed3e6b.mp4[/video]

I know basically feck-all about this but I happened to watch some of this fella’s amazing tutorials recently and he gets this problem when using Camtasia:UE4 Tutorial: Basic Movement with Root Motion - YouTube
You can look there and see what other clues you may find but as I understand it, exporting the animation with Camtasia running will cause this to become permanently part of the exported animation, and I think having Camtasia open whilst attempting to play a perfectly exported animation in UE4 will cause the animation to play back incorrectly. If you don’t use Camtasia, that doesn’t mean some other software isn’t affecting you. Try closing everything but your modelling software and UE4. If that doesn’t work, try restarting your PC and then opening only your modelling software and UE4. If that’s not it, I’m unfortunately not going to be very helpful. Best of luck.

This is still an issue. It’s occurring on my own animations too, except in the hands, and I still have no idea what is causing it. Here is a video:

I’m digging this thread from the grave.
Did you guys used some import scaling while importing those?
Still happens to me on 4.24.1

For the sake of future searchers - just solved this myself for a creature whose wrists/ankles were jittering upon import (both setup as IK targets, which I think is where this happens most often).

In the FBX Import Options dialog, turn on “Preserve Local Transforms” and it fixed the issue for me. (Also: “Use Default Sample Rate” set off, “Import Custom Attribute” set on).

Thanks for this solution, just saved me a long time figuring things out, I use Blender and don’t have other softwares to test if the error was in Blender export or in UE4 import and that solved it, not only shaking but some animations would also have weird bones that keep rotation(even if it wasn’t happening in the Blender animation).