Download

Animation plays more than it should, starts at random frames

I have an inplace reload animation that I took from PistolAnimSet Pro.

I hooked it up in my character’s Animation Blueprint, so it plays whenever the Reloading Variable is true via Blend Pose by Bool.
image

But the weird thing is, the animation plays at random frames each time it is triggered, even when the start position is 0.
At the first call, it starts from frame 0, but at the end, it doesn’t end, instead it loops for a few extra frames. Then on the next call, it seems like it starts from the last frame the loop ended. Making it look like it’s not starting from 0 but random points instead. It’s really problematic and I haven’t been able to find any answers as to why this happens.

Please help me.

Why is it looping? Disable loop.

If I disable loop, it gets stuck after playing the animation.

There’s an option for the animation that makes it reset any time it is entered.
Usually those are set up correctly by default. You could try just dragging in a new animation (or the same one)…

I’ve tried everything. It gets stuck after it plays.
Then I tried with state machine. It has the same problem, for some reason the animation starts from a random point everytime it’s called.

Is this a bug? If it is then it has totally kiled my project, I don’t think I can continue from here, especially when the engine doesn’t want to cooperate.

On the blend node there’s definitely an option to reset child that you can toggle on.