animation playing inbetween/sub frames

I have an animation that I uploaded from maya on 30FPS, imported it to unreal, and same 30FPS.
and when I watch the animation in unreal I see that it is playing sub frames.
In my animation, I have really fast movement on one frame and instead of playing it on one frame its playing it on two and it causes weird frames on the animation.
How can I fix that instead of setting it to step mode?

This happens because of the key interpolation, you can disable it by setting the “Interpolation” value to “Step” under the first category “Animation” of the animation “Asset Details” tab.


when I do that the animation is choppy