Animation Overlapping Vertices

I am skinning a character in 3DS Max, and it has turned out real well, and I have downloaded quite a few nice bip animations online. The only issue is that at a few points of the animation, the arms overlap and go onto the torso at the chest region. The biped files have keys for every frame, so editing them would be tedious. Is there a recommended way to fix this? To prevent the vertices from overlapping?
Thanks in advance!

I suppose the vertices overlap becaues of a foul retarget?
Does maya have a feature similar to mayas animation layers? That way you could layer a slight correction in rotation on the arms on top of the base animation very easily.

But just to be sure Im getting your question right you might want to post a small screenshot of the problem.

The arms sorta disappear into the torso, like this:9dbe947e97c894e9f83f6fb340a5bac1bddbe422.png

That can be several things… Either the bones are in wrong positions or the anim is a bit too extreme for those proportions and needs adjusting… or both.

If you want to go full advanced you could try upgrading the rig to have a bit of collision on some additional tweaker bones for the clothes. But if the underlying skin also intersects like that, then that might give unexpected results.

I think your best bet is to just tweak the animation so those extreme poses still work with that model.

You can use Biped’s animation layers to tweak the animation and smooth out “bad” poses, but I’d suggest making sure your model form and skeleton placement is good for the model to deform optimally.

So anyway, if you have your guy rigged / skinned and you test deform and he works, then you apply animation and it seems not to work so nicely, then obviously you just need to tweak the animation. But make sure first you test it “manually” and be happy with results before worrying about dealing with any animations and stuff.

With your guy here it seems like you have the bone placed high on the arm which leaves a lot of the model underneath. So when the arm bends down it means that basically more than half of the arm thickness is underneath that bend, so that will all push into the body. His body also seem fairly wide making it seems even worse. So in my opinion some different tweaks are needed, model wise and rig wise to make the arm “feel” better when it bends down. Ultimately though you will end up with some overlapping because that’s just the nature of things. You don’t have per vertex collision, and that’s not even an option, so you just need to tweak it to feel ok with regards to the overlap that you inevitably will get. When you come to import animations on there, you can tweak poses to make it less obvious, using animation layers, it’s not too bad of a job. You don’t have to tweak individual keys.