Download

Animation Notify Sounds Don't Work when Simulated

Hi, I had a scene I built back in 4.12 previews with some sound notifiers added to character animations. Now I continue working with that scene in 4.12 release version and sounds just stopped playing when I hit Play to simulate my Sequencer animations. When I hit play in Sequencer though, all sounds play as needed. Only when simulate they just refuse to play.

Here are some screenshots of my animation notify markers and of a sound cue I use for this one. Even in animation preview window all sounds do play as needed. But not when I simulate the whole sequence. And there is a screenshot of my Sequencer with the character selected.

All other sounds DO play when I simulate. For example I have lots of sounds triggered by event track, all of them do play. Ambient sound cues I placed around the level do play as well. Only Notifies refuse to play.

[SPOILER]


d21252954d0166255c8f8f94ff44d2fab511bdf4.jpeg
f3bdcc2467ad58b6b2f13f44c7e4fccfcaecba02.jpeg[/SPOILER]

I just tried to create a new empty level and add a character there as well as animations and create a small Sequencer sequence. All animation notify sounds worked both in PIE and in the Editor.
So it looks like my older project from 4.12 version is bugged or broken for some unknown reason. Does it mean there is no way to restore it so I have all sounds playing properly?

Problem was solved. It appeared that all sockets I used for notifies got removed when I reimported the mesh. That was the reason notifies didn’t work. I recreated the sockets and everything works now.