Download

Animation not working when enabling physics

[SEE SOLUTION BELOW (4th Answer), FELLOW GUYS LOOKING FOR AN ANSWER]

Hey guys,

the animation of our vehicle don’t work when enabling physics, but work when disabling it. (As a side information, it is not a physx vehicle, so we have custom vehicle animation and no “WheelHandler”).
The skeletalMesh uses a animation Blueprint, and I also tried setting SetAllBodiesPhysicsBlendWeight to 0.

And ideas why the animation don’t work when enabling physics?

Thanks a lot :slight_smile:

Nobody has an idea? :frowning:

You probably need to supply more detailed information about how your ‘vehichle’ is set up.
How does it run without physics.
What do you do yo enable it.

It is a skeletal Mesh Component with 5 Bones:

The Car Body as Root, and the 4 Wheels as Wheels. Therefore we use a Physics-Asset. The physics are pretty arcade, so beside line traces from the wheels and collision there is not much real physics in our cars. When setting the wheel-bones to “Kinematic” the animation plays, but the car flys straight up into the air, also the wheels then don’t perform collision checks anymore.

Honestly, we don’t need a solution with our current Physics Asset. If anyone has any idea / tip how to make a vehicle skeleton that has collision but can move it’s bones by animation, we would be very thankfull :slight_smile:

Okay, I FINALLY got it, and the solution is really really a brain****, well let’s say, I don’t understand it. But after checking out the Physics Anim Blending Content Example I noticed that the Hero TPP doesnt has Simulate Physics checked in the default panel, but sets the bones manually to simulate each tick. After doing the same for our project it worked.

I mean… why?

Yes I am also just working with bone physics and it is a bit hard to figure out how it fits together.
I think you should be able to set physics to ON only on BeginPlay. I just posted about my woes here, :slight_smile: