Animation not working on mesh (new to UE5)

I am very new to UE5 and currently want to do cinematic animations in sequencer. I have a firm grasp on control rig and currently all my characters needed for a scene have control on them. In sequencer I am trying to add premade animations that I can blend and use control rig to finish out custom scenes. I have been able get all animations shared across all characters from asset details page. But when I use any premade animation in sequencer I can see the skeleton of the animation and its moving but my mesh is not moving. I know it might be something simple but I am very new and don’t know where to look or what to do. Any help is greatly appreciated.

I don’t know exactly why it’s like this, but I just delete the CR track when I want to play a specific animation in Sequencer. If I want CR on top of that, I then right click the skeletal mesh track and choose Bake to Control Rig so that the animation frames are transferred to the rig in case I want to add new keys or a new animation layer (additive section).

So I just tried that and its still not working, at least not correctly at all.

Hey @SeaDogAnimations!

I’m not seeing a skeletal mesh component in your model in the sequencer. Am I just missing it or is it not there? Your premade animations may not be playing due to requiring a skeletal mesh component to play on.


Hopefully the above provides a lead into what may be going wrong.

Thankyou @Quetzalcodename believe this is the issue as none of my control rigs have a mesh assigned like the picture you attached. I looked through the doc link you sent and don’t see a solid answer. Is there else where to look? google does not seem to have what I need. Do you happen to know how I can fix my rig to have the skeletal mesh as well?

I don’t think the missing SkeletalMeshComponent is the issue - if there is only a single skeletal mesh in your Actor, then that skelmesh will be used.

A couple of things to double-check:

  • How did you create the Control Rig track in Sequencer?
  • In your screenshot, both the Control Rig track and Animation track are active. Do you see any different results if you de-activate the Animation track?

@Jeremiah3D No difference if I disable the animation. The Control rig is a copy of the original rig from the manni project provided in unreal marketplace. I drag and drop the character into the scene and then add to the sequencer and thats what shows up for me as far as controls. If I delete just the ACSU_CR right above animation then the animation will play. But then I loose control rig. I was able to get the mesh and control into one but its still not working.

I have tried a new control rig still not luck. I must be missing something small

We ran into this problem recently and it might be the case that the Skeletal Mesh is prohibiting the animations, like ignoring it due to the skeletal adjustments properties. We adjusted the rig to have the fingers squeeze the handle of a weapon tighter in the Cinematic Trailer and no animations could be updated, changed, or added after the finger bone’s adjustment.

Our Solution: Delete the “Sequencer” adjustments and create a separate animation the does the finger adjustments or head movements and add them in Animation tracks.

Hope that helps at all.