Animation not playing properly


I’ve encountered a weird problem when doing animation for a game.
all the animation used to be working properly before, and because the texture and UV need to be updated, I imported a new model using the exact same skeleton.
And some of the animations stopped working in the game, so I checked them, but everything works fine in animation preview.
but when I put the animation in the blueprint, it doesn’t work anymore. the animation plays correctly, the sound cue and event notification fires normal, just the model doesn’t move at all.

the left is animation preview, it works fine, right is when I put the skeletal mesh in the pawn, directly using animation asset(looping) but the model doesn’t move.
I am soo confused and tried a lot of ways to fix this, but I can’t find the reason. I tried to drag the animation directly into the scene, it doesn’t move either.

animation asset setup
Is there anything wrong with my animation setup?
Any help is appreciated, Thanks!

I currently have the same problem. Did you find the solution?


duplicating those animation seems fixed the problem for me.
I still don’t know what the problem was. You can try it, but no guarantee that will fix your problem.


I’ve created dozens of AnimBlueprints and just now ran into this same (or similar) problem out of nowhere. When I put the skeletal mesh in a blueprint and give it the AnimBlueprint, the animation shows up correctly in the editor, but the animation instance is removed in the scene. The setup is very basic and exactly the same as working characters in the same scene.

Recreating the blueprint and copying all the content over with no changes fixes it.