Download

Animation Montage Won't Play

I’m trying to set up a dodge animation for my character. I have a pretty simple setup already for landing animations, which also use montages. However, using a similar setup I can’t get my montage to play on a simple button press event.

I have it bound to space bar and I’m using a landing animation as a placeholder, I’ve tried with various anims but nothing works. In this video, you can see how I have it all set up. Character blueprint calls an event in the animation blueprint which tells it to play the landing animation montage. It doesn’t play. Also shown is that I’ve set up the slot and slot name in the ABP and anim montage respectively. Kinda lost here, my only guess would be to add the dodge to the state machine, but I’m planning to have potentially hundreds of attacks too and that would get messy.

Lend me your aid

We can see it saying “Hello” in preview when you press the button, so it has to be something with either the “self” call from the Get Owning Component or however you are loading in the “Montage to Play.” I can’t see your variables so I can’t be sure how you’re passing around exactly which montage you’re trying to play from this, but I would suspect that’s where the issue is.
Have you tried disconnecting the “Montage To Play” from that node and just selecting the one you want in its place?
playmontage
This is what my montage-on-button-press nodes look like and they seem to be accomplishing what you’re trying to do. Either way, it’s the next logical step to debugging here, I believe.