Animation Montage not playing

Hi all,

Having some trouble here with an animation system. I’ve got a reload animation for my character which is done through an animation montage its animation blueprint, but I also have a corresponding animation for the weapon he’s holding that I want to be controlled by a montage in the same way. I’m attempting to play the weapon animation through the character’s animation blueprint, but the montage isn’t playing, and I’m not having any luck figuring out how to do it through the character blueprint either.

Anyone reckon they can help me out here?

Dollars to donuts this is because of the animation slot. Happens to me all the time, create anim montage, set it all up, playtest, doesn’t work, break down in tears, remember slots and laugh hysterically.

Have you set up any animation slots in your animation blueprint? If not, add a slot node, click the eyeglass in the details panel and create new slot. Name it something that makes sense. Plug your state machine into the slot node, the slot node into final animation pose. In the anim montage you select the slot you created.

Well sounds to me like you’re trying to play an animation montage for a seperate skeleton that doesn’t have an animation blueprint. That’s not gonna work.

The animation notify can be used to call an event in the character blueprint to play the correct animation for the weapon.

I’ve tried setting up the slots in the anim graph, but the one I’ve selected for the weapon’s montage isn’t an option - I suspect this is because the weapon uses a different skeleton than the character, but I can’t figure out any other way of getting the montage to play.

Well, yeah! That’s what I’m trying - I can’t think of any other method to get this to work, though. I can’t give the weapon its own animation blueprint because the reload system relies on notifies in the character’s animation blueprint.

I gave that a go! I tried this initially but couldn’t find the right Montage nodes - turns out that because it was set to context-sensitive they didn’t appear in the dropdown. The animations still won’t play, though - I’ve set all the slots up properly and everything - am I doing something wrong with the AnimInstance, maybe? the documentation on them is super unhelpful.

Hmm well like I said, anim montages need a defined slot to play. If you don’t have a blueprint for your weapon you can’t have slots for it.

Does it need to be a montage btw, can’t you just play the animation?

I’ve given it a basic animation blueprint to use just so it has slots - still no luck though. It needed to be a montage because its a shotgun-style reload where it loops a specific section while bullets are loaded into it, but I suppose I can just split that animation up into three separate ones until I find a better way of doing this.

Sounds pretty cool. If it’s added as a skeletal mesh I don’t see why it wouldn’t play a montage. As long as its set up with a final anom pose with slots and a state machine and the correct slot is set in the anim montage.

Thank you. I happened upon this early when trying to adapt a marketplace product and found your answer straight away. Fixed my issue and saved me a sh_ttonne of time. Appreciated.

Did you solve it?