Download

Animation mismatch after import

Hey everyone,

I posted a thread earlier about having trouble getting the animations to import into the editor after importing a skeletal mesh (https://forums.unrealengine.com/showthread.php?51289-Animation-did-not-import-from-3ds-max). The animation would not import at all, but to solve that problem I checked the box on the FBX Import Options ‘Import Animation’ Name____. I did not have a name for the animation but decided to try it anyways and it worked!

Now there’s a new issue. The animation now exists, but when I played it it’s only 4 frames long and isn’t anything like the animation in 3ds Max which is 100 frames long. See these two pictures below:

3ds Max - Animation is 100 frames long - moves up and down continuously
4c3f44b43df918d58aa706de57b6742fc797aa0d.png

UE4 - Animation is only 4 frames long - moves up and down then stops :frowning: whyyyy?
d9fa9e7e6d5abf5917e9a735f6870cc4864b80b9.jpeg

Has anyone had this problem before or has any idea on how to fix this?

In the import properties you can choose which frame length/time the engine should use → exported time, range,… :slight_smile: Just import it with another setting

Is this happening with every animation or just with a special one?

Thank you fighter5347! Yeah what I did was import as a skeletal mesh and did not check ‘Import Animation’ under the Skeletal Mesh import options, I then imported the animation separately using the same FBX file and used the Animation import options which is what you’re referring to. And then I did the range of 1-100 and it worked! Yes!!! :D:cool: