Animation Locomotion Library fails to compile on start and throws error when building project

Hi everyone,

Unfortunately every time I start Unreal Engine, my Third Person Animation Blueprint doesn’t compile, as it throws following errors:

After refreshing all nodes, the errors disappear and at first I thought nothing more of it, however when I try to package the project I get the following errors:

Same thing. I found this forum post:

where it is recommended to switch the LoadingPhase of the .uplugin file to “PreDefault”, which I did for both the Runtime and Editor Module of the Animation Locomotion Plugin.
This fixed the errors popping up when starting the editor, and I was able to build the project without any errors.

HOWEVER, all animation states which use the Animation Locomotion package are now broken and are not executed in the built game.

Any help would be highly appreciated, as I would like to use animation distance matching for my student project, and replacing all nodes of the library would take alot of time.

Thanks in advance

Hey @Thrasdor, welcome to the forums!
Which version of unreal are you using for your development?
You may need to be fully sure you’ve enabled the plugin because I know distance matching relies on two other blueprint components as well.

On the other hand, it may be worth looking into this advanced locomotion setup:

I’d say it may also be worth looking into copying the package and rebuilding the project. Maybe even updating your version of the engine.
I hope this can help!
-Zen :vulcan_salute:

Hi @ZenLeviathan,

Thanks for answering so quickly, I have definitely enabled the plugin and it works in the Editor, it only breaks in the built game. I am using Unreal Engine 5.1.

I looked into the Advanced Locomotion System too but this is not an option for us, as it is single-player only (We are making a coop game).

What exactly do you mean with copying the package? Copy it to where?
I tried moving the package to the Local Game Plugins folder, instead of the Engine Plugins folder with no success.

Thank you

Open Engine/Plugins/Animation/AnimationLocomotionLibrary/AnimationLocomotionLibrary.uplugin

Set LoadingPhase to PreDefault, it worked for me.

In version 5.2 this issue is still not resolved, that method you said is not working for me.

+1 a month later in 5.21

fatal error LNK1104: cannot open file ‘…~AnimationLocomotionLibraryEditor\UnrealEditor-AnimationLocomotionLibraryEditor.suppressed.exp’

This error was encountered after compiling 5.21 release from source, and then creating the Electric Dreams Sample project and trying to compile that.

same 5.2.1 here
set LoadingPhase to true may helps you to deal with this error

Same Problem, not solved in 5.3