Download

Animation Jitters

Hi there, I’m posting this thread because I couldn’t find any info or solution to my really annoying problem.
I work with 3ds max 2015 and mostly biped to create my rigs and animations. I always use the same workflow.
I created a character, which is a biped. Skinned the model onto it. reset Xform, set the skin pose etc… everything. Then I created my animation set. I always create an easy standBreathe animation for the idle, basically the animation where the character just stand there and breathe: so only some slight movement and absolutely no movement on the feet ( using the sliding key feature of the biped rollout), I usually create some in place attack animations, the character uses its upper body to perform attack and the feet stick on the ground.
After exporting everything and importing in UE4, when I check the animations there are these terrible shaking / jitters on the feet only and specifically the animation with the feet that should stick to the ground. I really can’t figure out what is causing this, googled around for hours tried all the export fbx settings possible, nothing… re importing the fbx into 3ds max doesn’t show any shaking or jitters. Asked a friend to bring the fbx into maya, same… no jitters. Brought the model in Sketchfab and unity no jitters…
This is the second character which has this terrible issue. I tried to export the fbx out of UE4 and import it 3ds max and there I could see the jitters, tried to set up some position and look at constraint to fix it, fixed in 3ds max but after exporting and reimporting the problem persists…
I’m really frustrated and out of ideas.
The only consistent thing with those 2 characters having this issue is that it only happens when the feet are sticking on the ground. What I don’t understand is that I have maybe 18 other characters that I created the exact same way with feet sticking to the ground as well and they never had this issue…
Any insight that could help me solve this would be greatly appreciated.
Thanks in advance for your help.
Best,

I’ve faced this issue while importing animations that were “smart baked” in Maya.
Not familiar with 3DS Max, but if you’re using Motion Trajectories, have you made sure that you do a plain and simple key bake of just the required bone transforms and for each frame? You can optimize this later in-engine, but it would be nice to test if baking keys per frame solves this problem.

Thanks for trying to help. I already tried to have one key per frame for those specific bones, bake everything on export in fbx. And the problem still persists. What I don’t understand is that all my other characters are done the same way and they don’t have this issue…

Hmm… three things you could check:

  1. Make sure you’re exporting in FBX 2014 format
  2. Make sure 3ds max isn’t implicitly converting animation curve tangents anywhere and
  3. Try increasing the sample rate while importing in Unreal

OK, I managed to fix this ugly issue. Thanks @xenlock for trying to help.
I managed to solve it by re drag and dropping the fbx that had the problem and by having these import settings:
1-skeleton: well use the skeleton that should be used, the one in T Pose.
2-uncheck Use Default Sample Rate
3-Check import Custom Attributes
4-check Preserve Local transforms

Looks like it’s some pretty silly settings and stuff, but hell, I spent sooo much time trying to figure that stuff out, browsing internet trying to find someone who would have had the exact same problem and with a solution. So here it is for me. I hope this would help some others. I feel sooo much better now that I can finish up some stuff on those 3 characters which had the same problem.

Cheers! :slight_smile:

Only worked in 3ds max for a short time and never done animation in it, I do animating through maya atm. But i was having this problem when i tried to import a animation into UE4 from maya.

I fixed it by baking the animation to the skeleton of my model before exporting just the skeleton as an fbx.

Then i re-imported it into maya on an earlier version of the rigged model with no key-frames on it.

From there i selected the skeleton and the model/mesh and exported them together as an fbx re-imported them into UE4 and the animation worked fine.

Hope that can help.

Thanks for posting the solution, not that i’ve run into it myself, but i’ll keep it in mind if i ever see something like this.

Thanks very much for posting the solution here!!! I finally solve the problem. I have a same problem with my character and I spent whole day trying new rigging, making the animations again and again, importing other bip files to see if it has this problem(which do not and makes me confused). The UE4 document only mentioned the setting as “If enabled, this will import a curve within the animation.”, still wondering about what does the curve mean here… Anyway, many thanks!

Preserve local transforms did the trick for me!!! Thanks so much;
I have a complex mechanical rig with multiple “aim at” bones and some were jumping out of place.

Thanks again @PROTOFACTOR](https://forums.unrealengine.com/member.php?24347-PROTOFACTOR)& @xenlock](https://forums.unrealengine.com/member.php?9983-xenlock)

you’re welcome! glad this helped you out! :slight_smile: