Animation Imports not Full

Is it happening with that specific animation? If not, can you provide a sample file we can take a look at?

Hey, I recently was having an issue with importing my animations. They will only Import about half of the animation before it starts over. I have tried all the import settings in UE4 and checked my FBX file to see if it was messed up and it was not. It seems to be an issue with the amount of frames. My FBX file says that there are 24 frames, but UE4 is telling me there are 2-4 frames. Has anyone else had this issue? Is there some setting i am just missing?

It seems to be with every animation i import. Here is the FBX and MB files if you want to check it out. It is just a basic falling animation so that i can test what i am doing, but when i import it- it looks like it has glitched out because the end half of the animation is just missing. Wait i cant upload the file for some reason…

The links request permission to download.

I still dont know what happened but i figured it out. i dont seem to be having the issue anymore.

Any chance you know what you did to fix it? I’ve got the same issue and im pretty stumped…

Hey I just experienced this issue today. I use Maya 2015. On the Bake Animation export options, I selected Resample All and it solved the problem. I see this was 2 months ago so hopefully you aren’t still having that problem. For anyone else reading this, hope it helps you.

Apologies for not answering sooner. It was so long ago but it was indeed the way we are exporting them from maya. I found an old email that explained what had worked for me at the time.

In order to get UE4 to recognize an animation. In maya when you export select the root joint and then click Edit > Select Hierarchy . Then export selection with Animation bake animation on. Then import, and it should be recognized as an animation.

When the import did not recognize the file as an animation more often than not the problem we had would occur. Hope it helps.