Download

Animation Exported From Blender Appears To Be Broken.

Hello, I recently made a character and animation in Blender 2.7.
The character itself exports fine, but the animation breaks, with the bones being located in the wrong place.
The error message when this happens is, “Imported bone transform is different from original.”
I’m not sure what is causing the error, and after trying many times to fix it, I’m almost ready to give up.

Here’s the link to both the model, and the animation.
https://www.dropbox.com/s/vdmnz9cw26x3uel/Guy1.fbx?dl=0
https://www.dropbox.com/s/5x4ungrfguukm6i/Guy1Idle.fbx?dl=0

There are a number of similar posts on the AnswerHub that you might want to check out. I browsed through some and found this solution that may work for you: “hit space bar and type bake action, click that then remove your constraints.”

When the upper solution doesnt work, make sure to :slight_smile:

  1. go to object-apply-scale/rotation/location
  2. export the mesh + animation in one file

or upload the .blend somewhere so that we can take a look at it

Here is the .Blend file, thank you so much for helping!
https://www.dropbox.com/s/rbgzvjai8qlgkj2/Guy1Idle.blend?dl=0

Ok, as I said → do the stuff with object-apply-… for your armature + the mesh. Then export it with the default settings and import it with “import animation” enabled (currently using UE 4.6 and blender 2.70) :slight_smile:

(the last pic shows the idle animation)
char.jpg

It didn’t seem to work, I’m using Blender 2.70 and Ue4 4.5.1.
Here’s what it looks like in editor.
UE4Editor 2015-01-07 11-45-11-38.jpg

Ok, wait a sec. I will try it with 4.5.1 :slight_smile:

Edit: Hmm in my case it works

Try it with this fbx file: test.rar - Google Drive

It worked with your file, thank you!
Though I’m still not sure why mine won’t work.

Also when you export it from my .blend file?

It doesn’t seem to work, even when i export with your blend file.
I’m starting to think it might be my fbx exporter.

Hmm, reinstall blender and then try it again, because I use the unmodified exporter from blender 2.7 :slight_smile: + could you post your entire export/import process

I installed the newest version of Blender, and then tried to export with the default fbx exporter.
ee31fed406da59cc1da0a4b62e45b9df3eb6dbaf.png My export settings.
ee133321fb1ab0c511adea915148be70a4568381.png My import settings for Ue4.
d54067bf81fd40574fd7785683d9cbf85dd98cc3.jpeg After import, with some of the errors at the bottom.

What’s the result? -> for the smoothing error = enable smoothing in blender (but atm that’s not important as we somehow have to solve your problem :))

Btw, dont use a blender version higher than 2.70, because it could be that you get problems when you export/import skeletal meshes :wink: But somehow I dont understand why it works in my case…
Have you already tried the suggestion from Steve?

I have tried it, but it resulted in the same error.
I’ll try using Blennder 2.70 in a bit.

try unticking the the import option “Import meshes in bone hierarchy”

those log warnings seem to be coming from the bones !!!

That didn’t seem to work either.

There is a bug in the blender fbx exporter when doing animations. It works 99.9% of the time, but the other 0.1% will drive you nuts. The guys who are maintaining the fbx exporter for blender have been working on it, but the official fbx format is very closed source with no documentation making it very difficult to create an exporter for blender.

There is a work around you can try which is to add a small amount of movement in the bones that are not working. Make sure all 3 axis have some movement. It can be a tiny amount, but not zero. You’ll need to release any axis locks on rotations.

Thank you, I know they must be working hard on it, and I think they’re awesome for doing it!:smiley:
I think I’ll try doing what you said.

had a chance to check you blend file, please don’t offense but in nearly every blender to UE4 tutorial i know they mention the SCALE and how important it is to get it right, atm it looks like your using the standard scale settings which means when you import your character into unreal is about 2 UU in height or 2cm this causes problems asa the bones are to close together.

i suggest you delete the anim from blender, parent the mesh to the armature , scale by 100, use ctrl+a to reset scale/rotation, export the character and in UE4 compare the size with the Unreal blue guy

once thats ok export each anim you do into a separate fbx file then in ue4 just import the anim onto the skeleton

Keep in mind that Blenders fbx exporter is in development. The maintainer has put up a git source (Sorry couldn’t find it since I solved this problem). The solution to these issue was by using the autodesk fbx converter. First exporting as ascii 6.1 then converting it to binary through the converter which is free. This may or may not correct the issue… OH and on the scale issue if you go to scene make sure it is set to metric, scaling is very touchy between Blender and UE4.